Bug 234325

Summary: pmcstat seems to be broken in sampling mode (at least on amd hardware)
Product: Base System Reporter: shamaz.mazum
Component: binAssignee: freebsd-bugs mailing list <bugs>
Status: New ---    
Severity: Affects Only Me CC: cem
Priority: --- Keywords: regression
Version: 12.0-RELEASE   
Hardware: amd64   
OS: Any   

Description shamaz.mazum 2018-12-24 07:41:50 UTC
Hello. I use FreeBSD 12.0-RELEASE on two machines (one with Ryzen 5 1600X processor and the other with FX-6300).

Recently (presumable after upgrading to 12.0-RELEASE) pmcstat stopped working in sample mode.

I run it as:
`pmcstat -P instructions -O test.out -n 65536 ./noisecpu` on FX-6300
or
`pmcstat -P ex_ret_instr -O test.out -n 65536 ./noisecpu` on Ryzen

and then I run `pmcstat -R test.out -g`

In both cases it creates directories (e.g. ex_ret_instr) which are either empty or containing only kernel.gmon

`noisecpu` is computation heavy program, calculating value noise on a large grid and works for ~8 seconds.

Conversion statistics usually looks like following:
#exec/elf 1
#samples/total 169
#samples/unclaimed 165
#callchain/dubious-frames 165

In counting mode (with -p argument) everything seems to be working. Can anybody confirm this?