Bug 234876

Summary: [PATCH]: x11/nvidia-driver: Don't use NVidia-provided libGL.so/libEGL.so/libGLESv2.so
Product: Ports & Packages Reporter: Neel Chauhan <nc>
Component: Individual Port(s)Assignee: Alexey Dokuchaev <danfe>
Status: Closed DUPLICATE    
Severity: Affects Some People CC: nc, rhurlin, tijl
Priority: --- Flags: bugzilla: maintainer-feedback? (danfe)
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226403
Attachments:
Description Flags
Patch (Revision 1) none

Description Neel Chauhan freebsd_committer 2019-01-11 15:44:47 UTC
Created attachment 201032 [details]
Patch (Revision 1)

If I use GNOME and GDM on a computer with a NVidia GT 1030, and use the nvidia-driver from pkg, I get errors like this:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

GDM is also on a blank screen.

My setup is:

 * HP Slimline 290-p0014
 * Intel Core i7-8700
 * 24GB DDR4 (8GB HP OEM, 16GB G.Skill)
 * 512GB NVMe (Patriot SSD)
 * NVidia GT 1030 (2GB, Zotac card)
 * FreeBSD 12.0

My patch is attached and is tested to work with GDM and GNOME. It was originally from Bug 226403 but rebased on the current Ports tree.
Comment 1 Tijl Coosemans freebsd_committer 2019-01-18 17:54:07 UTC

*** This bug has been marked as a duplicate of bug 226403 ***