Bug 235104

Summary: net-im/psi fails to build with recent textproc/hunspell 1.7.0
Product: Ports & Packages Reporter: VVD <vvd>
Component: Individual Port(s)Assignee: Jan Beich <jbeich>
Status: Closed FIXED    
Severity: Affects Only Me CC: office
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Adding support of hunspell 1.7 none

Description VVD 2019-01-21 10:14:30 UTC
Created attachment 201304 [details]
Adding support of hunspell 1.7

After update textproc/hunspell to 1.7.0 net-im/psi fails to build:
…
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/local/lib/libX11.so
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find Hunspell (missing: HUNSPELL_LIBRARY)
Call Stack (most recent call first):
  /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/FindHunspell.cmake:79 (find_package_handle_standard_args)
  src/CMakeLists.txt:135 (find_package)


-- Configuring incomplete, errors occurred!
See also "/tmp/work/usr/ports/net-im/psi/work/.build/CMakeFiles/CMakeOutput.log".
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net-im/psi
*** Error code 1

Stop.
make: stopped in /usr/ports/net-im/psi

Patch is in attach.
Comment 1 commit-hook freebsd_committer 2019-01-21 10:43:23 UTC
A commit references this bug:

Author: jbeich
Date: Mon Jan 21 10:42:45 UTC 2019
New revision: 490850
URL: https://svnweb.freebsd.org/changeset/ports/490850

Log:
  net-im/psi: unbreak HUNSPELL=on after r490671

  CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
    Could NOT find Hunspell (missing: HUNSPELL_LIBRARY)

  PR:		235104
  Submitted by:	VVD
  Pointy hat to:	jbeich

Changes:
  head/net-im/psi/files/patch-cmake_modules_FindHunspell.cmake
Comment 2 Jan Beich freebsd_committer 2019-01-21 10:45:24 UTC
Sorry, I've got distracted by testing another breaking change and forgot to test consumers with OPTIONS_SET+=HUNSPELL. Only deskutils/treeline and net-im/psi don't enable HUNSPELL by default.