Bug 235472

Summary: [panic] Kernel panic page fault in softclock FreeBSD-12.0
Product: Base System Reporter: Palle Girgensohn <girgen>
Component: kernAssignee: freebsd-bugs mailing list <bugs>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: chris, markj
Priority: --- Keywords: panic, regression
Version: 12.0-RELEASE   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
core.txt.0 none

Description Palle Girgensohn freebsd_committer 2019-02-03 22:43:18 UTC
Created attachment 201700 [details]
core.txt.0

panic: page fault

GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...

Unread portion of the kernel message buffer:


Fatal trap 12: page fault while in kernel mode
cpuid = 1; apic id = 01
fault virtual address	= 0x0
fault code		= supervisor read instruction, page not present
instruction pointer	= 0x20:0x0
stack pointer	        = 0x28:0xfffffe017b1ee938
frame pointer	        = 0x28:0xfffffe017b1ee9e0
code segment		= base rx0, limit 0xfffff, type 0x1b
			= DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags	= interrupt enabled, resume, IOPL = 0
current process		= 12 (swi4: clock (0))
trap number		= 12
panic: page fault
cpuid = 1
time = 1549154153
KDB: stack backtrace:
#0 0xffffffff80be7977 at kdb_backtrace+0x67
#1 0xffffffff80b9b563 at vpanic+0x1a3
#2 0xffffffff80b9b3b3 at panic+0x43
#3 0xffffffff8107496f at trap_fatal+0x35f
#4 0xffffffff810749c9 at trap_pfault+0x49
#5 0xffffffff81073fee at trap+0x29e
#6 0xffffffff8104f315 at calltrap+0x8
#7 0xffffffff80bb5a39 at softclock+0x79
#8 0xffffffff80b5ee17 at ithread_loop+0x1a7
#9 0xffffffff80b5bf33 at fork_exit+0x83
#10 0xffffffff810502fe at fork_trampoline+0xe
Uptime: 2h16m58s
Dumping 16189 out of 261976 MB:..1%..11%..21%..31%..41%..51%..61%..71%..81%..91%

Readi
Comment 1 Palle Girgensohn freebsd_committer 2019-02-03 22:50:22 UTC
Ths system has worked reliably for a few years. After the recent upgrade to FreeBSD-12, we see frequent crashes (as in a handful per week).

The system is busy running jails using VIMAGE with netgraph networks stacks, but nothong changed except upgrading to 12.0, so I suspect a regression in the 12 kernel. 

It is a GENERIC kernel.
Comment 2 Mark Johnston freebsd_committer 2019-02-04 18:06:57 UTC
I suspect that this is a dup of PR 234296.  We'll be releasing a 12.0 EN for it shortly, but in the meantime, please try r343454 if you're able.
Comment 3 Mark Johnston freebsd_committer 2019-02-05 18:56:33 UTC
I will dup this now that the issue is fixed in 12.0-p3.  Please reopen if you observe the panic after updating.

*** This bug has been marked as a duplicate of bug 234296 ***