Bug 235524

Summary: igb ethernet interface loses active link state
Product: Base System Reporter: Denis Ahrens <denis>
Component: kernAssignee: freebsd-net mailing list <net>
Status: New ---    
Severity: Affects Only Me Keywords: IntelNetworking
Priority: ---    
Version: 12.0-STABLE   
Hardware: amd64   
OS: Any   

Description Denis Ahrens 2019-02-05 13:54:02 UTC
my machine uses an igb interface for pppoe to a dsl-modem. after some load on the interface (max 16mbit) the link state changes to DOWN.

sometimes using "ifconfig pppoe0 down" and then "ifconfig pppoe0 up" helps but mostly not and the only solution is to reboot the machine.

Every aspect of involved hardware changed over the years but the problems persists.

funny thing is that the link goes active if I run "ifconfig pppoe0 down". but as soon as I run "ifconfig pppoe0 up" the link state goes to inactive.

first messages in var/log/message when this happens:

Feb  4 16:20:14 monolith kernel: igb3: TX(0) desc avail = 42, pidx = 876
Feb  4 16:20:15 monolith kernel: pppoe0: link state changed to DOWN