Bug 235617

Summary: www/firefox: is crashing all the time
Product: Ports & Packages Reporter: Victor Sudakov <vas>
Component: Individual Port(s)Assignee: freebsd-gecko mailing list <gecko>
Status: Closed Works As Intended    
Severity: Affects Some People CC: grahamperrin, vas
Priority: --- Flags: jbeich: maintainer-feedback+
Version: Latest   
Hardware: amd64   
OS: Any   

Description Victor Sudakov 2019-02-09 11:55:18 UTC
firefox-65.0_1,1 from the official FreeBSD packages is crashing all the time with signal 11. Please let me know if I can provide more useful feedback than this, I'd be happy to:

[vas@vas ~] gdb /usr/local/lib/firefox/firefox firefox.core 
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `firefox'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000080208f47a in ?? ()
(gdb) quit
[vas@vas ~] gdb /usr/local/lib/firefox/firefox firefox.core
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `firefox'.
Program terminated with signal 11, Segmentation fault.
#0  0x000000080208f47a in ?? ()
(gdb) where
#0  0x000000080208f47a in ?? ()
#1  0x000000080208f444 in ?? ()
#2  0x0000000000018916 in LZ4_decompress_safe_forceExtDict ()
#3  0x0000000810e39675 in ?? ()
#4  0x00007fffdf58a4a8 in ?? ()
#5  0x0000000000000400 in .hash ()
#6  0x0000000000000000 in ?? ()
(gdb)
Comment 1 Graham Perrin 2019-02-09 17:03:40 UTC
Which version of FreeBSD?
Comment 2 Victor Sudakov 2019-02-09 17:08:00 UTC
(In reply to Graham Perrin from comment #1)
11.2-RELEASE-p6 amd64
Comment 3 Jan Beich freebsd_committer 2019-02-09 23:36:50 UTC
Did you read pkg-message after ports r480744?

The stacktrace in comment 0 is useless. Official packages have non-debug symbols, so there should be a lot less ?? (unknown) frames. However, symbols wouldn't help if the crash occurs in one of the dependencies or stack gets corrupted.

Anyway, I can't reproduce on 11.2 amd64. -RELEASEs default to /quarterly. If you're on /latest, built some packages, etc. document such differences. This is the first such report 3 weeks after 65.0 update. Make sure to check previous Firefox versions in case of a regression.
Comment 4 Victor Sudakov 2019-02-14 12:31:20 UTC
(In reply to Jan Beich from comment #3)
> Did you read pkg-message after ports r480744?

Setting "sysctl net.local.stream.recvspace=16384" has helped somewhat, thank you for referring me to that. However, my wife still complains about crashes, but I've not experienced a crash for several days after changing this sysctl.

I don't really know if I'm on /quarterly or on /latest, I'm actually on "pkg install www/firefox" from the official repo.

Yes, previous Firefox versions did crash too. 

Is there a way to obtain a useful coredump other than recompiling firefox from ports for debugging? I can even take pains to recompile it in my poudriere if I knew how to enable the debug symbols.
Comment 5 Victor Sudakov 2019-04-30 01:27:44 UTC
Setting "sysctl net.local.stream.recvspace=16384" has helped.