Bug 235646

Summary: lang/clojure: Update to 1.10.0.411
Product: Ports & Packages Reporter: Sebastian Schwarz <seschwar>
Component: Individual Port(s)Assignee: Tobias Kortkamp <tobik>
Status: Closed FIXED    
Severity: Affects Some People CC: freebsd-ports
Priority: --- Flags: freebsd-ports: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
clojure-1.10.0.411.patch none

Description Sebastian Schwarz 2019-02-10 17:42:04 UTC
Created attachment 201899 [details]
clojure-1.10.0.411.patch

Clojure 1.10.0 was release on 2018-12-03: https://github.com/clojure/clojure/blob/clojure-1.10.0/changes.md#changes-to-clojure-in-version-110

It now requires Java 8 or later.  This requirement was already present in the port's Makefile.

The port build cleanly under Poudriere on FreeBSD:12:amd64.
Comment 1 Jens Grassel 2019-02-10 17:53:43 UTC
Looks good to me, thanks for the contribution.
Comment 2 commit-hook freebsd_committer 2019-02-10 18:49:31 UTC
A commit references this bug:

Author: tobik
Date: Sun Feb 10 18:49:21 UTC 2019
New revision: 492628
URL: https://svnweb.freebsd.org/changeset/ports/492628

Log:
  lang/clojure: Update to 1.10.0.411

  Changes:	https://github.com/clojure/clojure/blob/clojure-1.10.0/changes.md#changes-to-clojure-in-version-110
  PR:		235646
  Submitted by:	Sebastian Schwarz <seschwar@gmail.com>
  Approved by:	Jens Grassel <jan0sch@mykolab.com> (maintainer)

Changes:
  head/lang/clojure/Makefile
  head/lang/clojure/distinfo