Bug 235653

Summary: x11/xcb-proto fails to install with python-3.6
Product: Ports & Packages Reporter: Mikhail Teterin <mi>
Component: Individual Port(s)Assignee: freebsd-x11 mailing list <x11>
Status: Closed Feedback Timeout    
Severity: Affects Only Me CC: marcus, ports-bugs, w.schwarzenfeld, zeising
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Use %%PYTHON_PYOEXTENSION%% instead of hardcoding "pyo" none

Description Mikhail Teterin freebsd_committer 2019-02-10 21:08:31 UTC
On a fresh 12-stable installation I get the below error. Indeed, the .pyo files listed do not exist. Instead there are .opt-1.pyc ones...

root@tulik:/usr/ports/x11/xcb-proto # make install
===>  Installing for xcb-proto-1.13
===>  Checking if xcb-proto is already installed
actual-package-depends: dependency on /opt/bin/python2.7 not registered (normal if it belongs to base)
===>   Registering installation for xcb-proto-1.13
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/__init__.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/align.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/error.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/expr.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/matcher.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/state.pyo:No such file or directory
pkg-static: Unable to access file /home/usr/ports/x11/xcb-proto/work/stage/opt/lib/python3.6/site-packages/xcbgen/__pycache__/xtypes.pyo:No such file or directory
*** Error code 74

Stop.
Comment 1 Mikhail Teterin freebsd_committer 2019-02-10 21:11:08 UTC
Actually, the build of x11-wm/xfce4 failed with that error. When trying to install just this port itself -- after make clean -- it attempts to use python-2.7, not 3.6.
Comment 2 Antoine Brodin freebsd_committer 2019-02-10 21:12:50 UTC
I can't reproduce the issue.
Comment 3 Mikhail Teterin freebsd_committer 2019-02-11 02:18:39 UTC
Created attachment 201912 [details]
Use %%PYTHON_PYOEXTENSION%% instead of hardcoding "pyo"

> I can't reproduce the issue.

Have you tried with python-3.6? Such as, for example, when building xfce4?

By default the port uses python-2.7, for which the pkg-plist is valid.

%%PYTHON_PYOEXTENSION%% should be used instead of the hardcoded "pyo" -- and, maybe, portlint ought to catch this.
Comment 4 Walter Schwarzenfeld freebsd_triage 2019-08-08 12:18:25 UTC
Status?

(installs for me fine with pytho3.6).
Comment 5 Niclas Zeising freebsd_committer 2019-09-14 19:47:42 UTC
Feedback timeout