Bug 235688

Summary: audio-openal-soft: linker error: /usr/local/bin/ld.bfd: final link failed: bad value
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: Tobias Kortkamp <tobik>
Status: Closed DUPLICATE    
Severity: Affects Many People Flags: bugzilla: maintainer-feedback? (tobik)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description O. Hartmann 2019-02-12 10:26:28 UTC
Port audio/openal-soft fails due to linker failure on poudriere-jail (FreeBSD 12-STABLE, see info below)  running on a host which is running  CURRENT natively (FreeBSD 13.0-CURRENT #177 r344044: Tue Feb 12 09:13:36 CET 2019  amd64). The problem persists now for a couple of days after updating the poudriere-jail from 12-RELENG to 12-STABLE; I'm adding the head of poudriere's log and the error of the linker itself as far as I could identify the location of its first occurence, see below.



[...]
=>> Building audio/openal-soft
build started at Tue Feb 12 08:57:16 UTC 2019
port directory: /usr/ports/audio/openal-soft
package name: openal-soft-1.19.1_1
building for: FreeBSD foo.buff 12.0-STABLE FreeBSD 12.0-STABLE 1200502 amd64
maintained by: tobik@FreeBSD.org
Makefile ident:      $FreeBSD: head/audio/openal-soft/Makefile 488341 2018-12-25 20:25:12Z tcberner $
Poudriere version: 3.2.8
Host OSVERSION: 1300011
Jail OSVERSION: 1200502
Job Id: 01

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1200502
UNAME_v=FreeBSD 12.0-STABLE 1200502
UNAME_r=12.0-STABLE
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.2.8
MAKEOBJDIRPREFIX=/pool/sources/12-STABLE/obj/
MASTERMNT=/pool/poudriere/data/.m/12-amd64-head-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=xterm
PWD=/pool/poudriere/data/.m/12-amd64-head-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=12-amd64-head-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/pool/poudriere/data/.m/12-amd64-head-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for openal-soft-1.19.1_1:
     CONFIG=off: Install configuration utility (needs Qt 4.x)
     EXAMPLES=on: Build and/or install examples
     JACK=off: JACK audio server support
     OSS=on: Open Sound System support
     PORTAUDIO=off: PortAudio library support
     PULSEAUDIO=off: PulseAudio sound server support
     SDL=off: Simple Direct Media Layer support
     SNDIO=off: Sndio audio support
===> Use 'make config' to modify these settings
---End OPTIONS List---


[...]
[67/70] : && /usr/bin/cc -fPIC -std=c11 -O2 -pipe  -fstack-protector -fno-strict-aliasing -O2 -pipe  -fstack-protector -fno-strict-aliasing  -Wl,--as-needed -fstack-protector -fuse-ld=bfd -shared -Wl,-soname,libopenal.so.1 -o libopenal.so.1.19.1 CMakeFiles/OpenAL.dir/OpenAL32/alAuxEffectSlot.c.o CMakeFiles/OpenAL.dir/OpenAL32/alBuffer.c.o CMakeFiles/OpenAL.dir/OpenAL32/alEffect.c.o CMakeFiles/OpenAL.dir/OpenAL32/alError.c.o CMakeFiles/OpenAL.dir/OpenAL32/alExtension.c.o CMakeFiles/OpenAL.dir/OpenAL32/alFilter.c.o CMakeFiles/OpenAL.dir/OpenAL32/alListener.c.o CMakeFiles/OpenAL.dir/OpenAL32/alSource.c.o CMakeFiles/OpenAL.dir/OpenAL32/alState.c.o CMakeFiles/OpenAL.dir/OpenAL32/event.c.o CMakeFiles/OpenAL.dir/OpenAL32/sample_cvt.c.o CMakeFiles/OpenAL.dir/Alc/ALc.c.o CMakeFiles/OpenAL.dir/Alc/ALu.c.o CMakeFiles/OpenAL.dir/Alc/alconfig.c.o CMakeFiles/OpenAL.dir/Alc/bs2b.c.o CMakeFiles/OpenAL.dir/Alc/converter.c.o CMakeFiles/OpenAL.dir/Alc/mastering.c.o CMakeFiles/OpenAL.dir/Alc/ringbuffer.c.o CMakeFiles/OpenAL.dir/Alc/effects/autowah.c.o CMakeFiles/OpenAL.dir/Alc/effects/chorus.c.o CMakeFiles/OpenAL.dir/Alc/effects/compressor.c.o CMakeFiles/OpenAL.dir/Alc/effects/dedicated.c.o CMakeFiles/OpenAL.dir/Alc/effects/distortion.c.o CMakeFiles/OpenAL.dir/Alc/effects/echo.c.o CMakeFiles/OpenAL.dir/Alc/effects/equalizer.c.o CMakeFiles/OpenAL.dir/Alc/effects/fshifter.c.o CMakeFiles/OpenAL.dir/Alc/effects/modulator.c.o CMakeFiles/OpenAL.dir/Alc/effects/null.c.o CMakeFiles/OpenAL.dir/Alc/effects/pshifter.c.o CMakeFiles/OpenAL.dir/Alc/effects/reverb.c.o CMakeFiles/OpenAL.dir/Alc/filters/filter.c.o CMakeFiles/OpenAL.dir/Alc/filters/nfc.c.o CMakeFiles/OpenAL.dir/Alc/filters/splitter.c.o CMakeFiles/OpenAL.dir/Alc/helpers.c.o CMakeFiles/OpenAL.dir/Alc/hrtf.c.o CMakeFiles/OpenAL.dir/Alc/uhjfilter.c.o CMakeFiles/OpenAL.dir/Alc/ambdec.c.o CMakeFiles/OpenAL.dir/Alc/bformatdec.c.o CMakeFiles/OpenAL.dir/Alc/panning.c.o CMakeFiles/OpenAL.dir/Alc/mixvoice.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_c.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse2.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse3.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse41.c.o CMakeFiles/OpenAL.dir/Alc/backends/base.c.o CMakeFiles/OpenAL.dir/Alc/backends/loopback.c.o CMakeFiles/OpenAL.dir/Alc/backends/null.c.o CMakeFiles/OpenAL.dir/Alc/backends/oss.c.o CMakeFiles/OpenAL.dir/Alc/backends/wave.c.o  -pthread libcommon.a -lrt -lpthread -lm && :
FAILED: libopenal.so.1.19.1 
: && /usr/bin/cc -fPIC -std=c11 -O2 -pipe  -fstack-protector -fno-strict-aliasing -O2 -pipe  -fstack-protector -fno-strict-aliasing  -Wl,--as-needed -fstack-protector -fuse-ld=bfd -shared -Wl,-soname,libopenal.so.1 -o libopenal.so.1.19.1 CMakeFiles/OpenAL.dir/OpenAL32/alAuxEffectSlot.c.o CMakeFiles/OpenAL.dir/OpenAL32/alBuffer.c.o CMakeFiles/OpenAL.dir/OpenAL32/alEffect.c.o CMakeFiles/OpenAL.dir/OpenAL32/alError.c.o CMakeFiles/OpenAL.dir/OpenAL32/alExtension.c.o CMakeFiles/OpenAL.dir/OpenAL32/alFilter.c.o CMakeFiles/OpenAL.dir/OpenAL32/alListener.c.o CMakeFiles/OpenAL.dir/OpenAL32/alSource.c.o CMakeFiles/OpenAL.dir/OpenAL32/alState.c.o CMakeFiles/OpenAL.dir/OpenAL32/event.c.o CMakeFiles/OpenAL.dir/OpenAL32/sample_cvt.c.o CMakeFiles/OpenAL.dir/Alc/ALc.c.o CMakeFiles/OpenAL.dir/Alc/ALu.c.o CMakeFiles/OpenAL.dir/Alc/alconfig.c.o CMakeFiles/OpenAL.dir/Alc/bs2b.c.o CMakeFiles/OpenAL.dir/Alc/converter.c.o CMakeFiles/OpenAL.dir/Alc/mastering.c.o CMakeFiles/OpenAL.dir/Alc/ringbuffer.c.o CMakeFiles/OpenAL.dir/Alc/effects/autowah.c.o CMakeFiles/OpenAL.dir/Alc/effects/chorus.c.o CMakeFiles/OpenAL.dir/Alc/effects/compressor.c.o CMakeFiles/OpenAL.dir/Alc/effects/dedicated.c.o CMakeFiles/OpenAL.dir/Alc/effects/distortion.c.o CMakeFiles/OpenAL.dir/Alc/effects/echo.c.o CMakeFiles/OpenAL.dir/Alc/effects/equalizer.c.o CMakeFiles/OpenAL.dir/Alc/effects/fshifter.c.o CMakeFiles/OpenAL.dir/Alc/effects/modulator.c.o CMakeFiles/OpenAL.dir/Alc/effects/null.c.o CMakeFiles/OpenAL.dir/Alc/effects/pshifter.c.o CMakeFiles/OpenAL.dir/Alc/effects/reverb.c.o CMakeFiles/OpenAL.dir/Alc/filters/filter.c.o CMakeFiles/OpenAL.dir/Alc/filters/nfc.c.o CMakeFiles/OpenAL.dir/Alc/filters/splitter.c.o CMakeFiles/OpenAL.dir/Alc/helpers.c.o CMakeFiles/OpenAL.dir/Alc/hrtf.c.o CMakeFiles/OpenAL.dir/Alc/uhjfilter.c.o CMakeFiles/OpenAL.dir/Alc/ambdec.c.o CMakeFiles/OpenAL.dir/Alc/bformatdec.c.o CMakeFiles/OpenAL.dir/Alc/panning.c.o CMakeFiles/OpenAL.dir/Alc/mixvoice.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_c.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse2.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse3.c.o CMakeFiles/OpenAL.dir/Alc/mixer/mixer_sse41.c.o CMakeFiles/OpenAL.dir/Alc/backends/base.c.o CMakeFiles/OpenAL.dir/Alc/backends/loopback.c.o CMakeFiles/OpenAL.dir/Alc/backends/null.c.o CMakeFiles/OpenAL.dir/Alc/backends/oss.c.o CMakeFiles/OpenAL.dir/Alc/backends/wave.c.o  -pthread libcommon.a -lrt -lpthread -lm && :
/usr/local/bin/ld.bfd: CMakeFiles/OpenAL.dir/OpenAL32/alExtension.c.o: relocation R_X86_64_PC32 against protected symbol `alcGetProcAddress' can not be used when making a shared object
/usr/local/bin/ld.bfd: final link failed: bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/openal-soft
=>> Cleaning up wrkdir
===>  Cleaning for openal-soft-1.19.1_1
build of audio/openal-soft | openal-soft-1.19.1_1 ended at Tue Feb 12 08:57:30 UTC 2019
build time: 00:00:14
!!! build failure encountered !!!
Comment 1 Tobias Kortkamp freebsd_committer 2019-02-12 10:27:36 UTC

*** This bug has been marked as a duplicate of bug 235603 ***