Bug 235717

Summary: lang/mono IPv6 support
Product: Ports & Packages Reporter: ps
Component: Individual Port(s)Assignee: freebsd-mono (Nobody) <mono>
Status: Closed DUPLICATE    
Severity: Affects Some People CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (mono)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Change AF_INET6 to 28 none

Description ps 2019-02-13 16:59:57 UTC
Created attachment 201987 [details]
Change AF_INET6 to 28

Mono incorrectly assigns AF_INET6 for FreeBSD since FreeBSD uses the MacOsNetworkInterfaceAPI.  AF_INET6 is 30 on MacOS but 28 on FreeBSD.  This allows mono to connect to IPv6 only hostnames:

csharp -e 'new System.Net.WebClient ().DownloadString ("http://www.v6.facebook.com/status.php")'
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-02-14 11:41:28 UTC

*** This bug has been marked as a duplicate of bug 235716 ***