Bug 235968

Summary: [PATCH] databases/tuning-primer support for MySQL 5.7 and MariaDB 10.x, fix some errors
Product: Ports & Packages Reporter: Miroslav Lachman <000.fbsd>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: New ---    
Severity: Affects Only Me    
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
support for MariaDB 10.x and MySQL 5.7 none

Description Miroslav Lachman 2019-02-23 19:49:46 UTC
Upstream version is not maintained and does not support newer MySQL versions like 5.7 or MariaDB with InnoDB. 
I created easy patch to add support for MySQL 5.7 and MariaDB 10.x and fix for two small bugs with JOINS and SLOW LOGS.
Based on MySQL 5.7 fix https://bugs.launchpad.net/mysql-tuning-primer/+bug/1565227

I do not know if this is the right way to patch this port because it does not have wrksrc dir. It directly installs distfile so I try to patch it in stagedir.
Comment 1 Miroslav Lachman 2019-02-23 19:50:27 UTC
Created attachment 202298 [details]
support for MariaDB 10.x and MySQL 5.7
Comment 2 Miroslav Lachman 2019-02-24 22:39:03 UTC
*** Bug 235967 has been marked as a duplicate of this bug. ***