Bug 236427

Summary: lang/J: installation overwrites jconsole from openjdk
Product: Ports & Packages Reporter: Bojan Petrovic <bojan_petrovic>
Component: Individual Port(s)Assignee: Dmitry Marakasov <amdmi3>
Status: Closed FIXED    
Severity: Affects Only Me CC: sevenjp, w.schwarzenfeld
Priority: --- Flags: sevenjp: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   

Description Bojan Petrovic 2019-03-09 20:33:26 UTC
If openjdk is already installed, installing lang/J will overwrite /usr/local/bin/jconsole.
Comment 1 João Neves 2019-03-10 13:46:54 UTC
(In reply to Bojan Petrovic from comment #0)

Ah, that's unfortunate. I'm in the process of finishing up the update to 807 (808 was apparently an erroneous release).

Will at least add a conflict check to prevent installation if openjdk is installed, will look into a better solution afterwards, if possible.
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-09 11:19:21 UTC
Version is now 807-release. Does the problem still exist?
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-09 17:03:50 UTC


seems solved. Can we close here?
Comment 4 commit-hook freebsd_committer 2021-03-16 21:15:39 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Mar 16 21:15:28 UTC 2021
New revision: 568616
URL: https://svnweb.freebsd.org/changeset/ports/568616

  - Mark BROKEN: does not compile

  /wrkdirs/usr/ports/lang/J/work/jsource-j807-release/jsrc/ar.c:254:70: error: implicit conversion from 'long long' to 'double' changes value from 9223372036854775807 to 9223372036854775808 [-Werror,-Wimplicit-const-int-float-conversion]

  - Fix CONFLICTS_INSTALL on openjdk* (conflict of bin/jconsole binary from J vs. symlink installed by openjdk* from post-install scripts) [1]
  - Fix WWW

  PR:		236427 [1]
  Reported by:	bojan_petrovic@fastmail.fm [1]

Comment 5 Dmitry Marakasov freebsd_committer 2021-03-16 21:16:35 UTC
(In reply to Walter Schwarzenfeld from comment #3)
bin/jconsole is not mentioned in openjdk plists as it's a symlink generated from post-install script, so this issue was not solved.  Additionally, CONFLICTS_INSTALL mentioned in J port were incorrect.

Fixing conflicts and marking J broken for it doesn't compile.