Bug 236843

Summary: devel/llvm60 and DEFAULT_VERSION=python=3.6 interference
Product: Ports & Packages Reporter: Hiroo Ono <hiroo.ono+freebsd>
Component: Individual Port(s)Assignee: Kubilay Kocak <koobs>
Status: Closed DUPLICATE    
Severity: Affects Some People CC: brooks, koobs
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description Hiroo Ono 2019-03-28 01:49:49 UTC
devel/llvm60 has dependency USES= python:2.7,build.
When building with DEFAULT_VERSIONS+= python=3.7, py36-setuptools is installed via dependency on py36-sphinx.
Then, USES=python2.7 has implicit depencence on py27-enum which pulls in py27-setuptools.
py27-setuptools and py36-setuptools conflict on /usr/local/bin/easy_install. 

Is there any workaround possible?
It may be just a limitation with llvm60. But llvm60 affects so many ports that it is difficult to set DEFAULT_VERSIONS=python=3.6.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-03-28 09:49:19 UTC
@Hiroo,

See: bug 226634 comment 8 (and read the original bug report as well). 

I believe this will be the same issue as yours.

I'll elaborate and extend Serges' comment to provide more detail there.

If it turns out that is not the issue, let us know.
Comment 2 Hiroo Ono 2019-03-28 14:55:19 UTC
(In reply to Kubilay Kocak from comment #1)
It was exactly the same problem, and rerunning poudriere was sufficient to solve it.
Thank you. So, it is not an issue, sorry.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-03-29 08:32:11 UTC
Good to hear Hiroo, thank you for following up
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2019-03-30 04:03:06 UTC

*** This bug has been marked as a duplicate of bug 226634 ***