Bug 236887

Summary: devel/glibmm: prevents debug symbols under WITH_DEBUG=yes/"Using USE_GNOME alone is deprecated, please add USES=gnome."
Product: Ports & Packages Reporter: Matthias Andree <mandree>
Component: Individual Port(s)Assignee: freebsd-gnome (Nobody) <gnome>
Status: Open ---    
Severity: Affects Some People CC: gnome, kwm, mandree
Priority: --- Keywords: easy, patch
Version: LatestFlags: mandree: maintainer-feedback+
Hardware: Any   
OS: Any   
Attachments:
Description Flags
glibmm: avoid INSTALL_TARGET=install-strip and use default install instead under !empty(WITH_DEBUG) mandree: maintainer-approval? (gnome)

Description Matthias Andree freebsd_committer 2019-03-29 21:58:11 UTC
Created attachment 203249 [details]
glibmm: avoid INSTALL_TARGET=install-strip and use default install instead under !empty(WITH_DEBUG)

When installing devel/glibmm under a WITH_DEBUG=yes regime, glibmm will strip its symbols nonetheless. (This showed when I was trying to debug graphics/rawtherapee.)

I am proposing and attaching a patch to avoid stripping everything under WITH_DEBUG.
Comment 1 Koop Mast freebsd_committer 2019-03-31 20:31:00 UTC
Shouldn't the code bsd.port.mk line 1765 take case of this?

https://svnweb.freebsd.org/ports/head/Mk/bsd.port.mk?revision=493977&view=markup#l1765
Comment 2 Matthias Andree freebsd_committer 2019-04-21 01:42:52 UTC
will have to re-check
Comment 3 Matthias Andree freebsd_committer 2019-04-22 22:39:10 UTC
It appears that the symbols are there after "make stage", but the unconditional "INSTALL_TARGET=install-strip" is misleading nonetheless, and that it hinges on overrides from bsd.port.mk is nonobvious at best.

There is also a new warning:

/!\ glibmm-2.56.0_1,1: Makefile warnings, please consider fixing /!\

Using USE_GNOME alone is deprecated, please add USES=gnome.
Comment 4 Matthias Andree freebsd_committer 2019-09-07 08:27:11 UTC
bump