Bug 237420

Summary: devel/kyua: "report" option not working correctly on version 0.13_2,3
Product: Ports & Packages Reporter: susan.stanziano
Component: Individual Port(s)Assignee: Julio Merino,+1 347 694 0576,New York City <jmmv>
Status: Open ---    
Severity: Affects Some People CC: dim, jmmv, susan.stanziano
Priority: --- Flags: koobs: maintainer-feedback? (jmmv)
Version: Latest   
Hardware: amd64   
OS: Any   

Description susan.stanziano 2019-04-20 19:40:38 UTC
I have kyua installed (version 0.13_2,3) on a SCO OpenServer10 R3M1 VM (based on FreeBSD10.3).  

If I run "kyua report --results-filter" I should only see failed tests, but I see all test results.

If I run "kyua report --results-filter=failed" as Enji suggested, I still see all results, and not just failed tests.

I installed FreeBSD12 on a VM with Kyua version 0.13_4,3 and the report option worked as expected and I see only failed tests.

Comment from Enji: "There are a number of kyua integration tests that fail on 10.x and 11.x. I wonder if the issue is a part of the root cause."