Bug 237919

Summary: devel/libunwind: libunwind-ptrace.so: undefined reference to lzma_index_size
Product: Ports & Packages Reporter: Yuri Victorovich <yuri>
Component: Individual Port(s)Assignee: Danilo Egea Gondolfo <danilo>
Status: New ---    
Severity: Affects Only Me CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (danilo)
Version: Latest   
Hardware: Any   
OS: Any   

Description Yuri Victorovich freebsd_committer 2019-05-16 08:35:26 UTC
One new port breaks:

> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_index_size
> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_stream_buffer_decode
> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_index_end
> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_stream_footer_decode
> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_index_uncompressed_size
> ld: error: /usr/local/lib/libunwind-ptrace.so: undefined reference to lzma_index_buffer_decode


This means that /usr/lib/liblzma.so needs to be added to link lines.
Comment 1 Yuri Victorovich freebsd_committer 2019-05-16 08:35:47 UTC
libunwind-20170615
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-09-07 09:45:20 UTC
Maintainer feedback!
Comment 3 Danilo Egea Gondolfo freebsd_committer 2019-09-08 11:25:58 UTC
In what case that happens? How can I reproduce this issue?

As far as I can tell, the configure script will find the liblzma automatically and link the libs against it.