Bug 238081

Summary: emulators/i386-wine-devel fails to build when GECKO option is set
Product: Ports & Packages Reporter: Grzegorz Junka <list1>
Component: Individual Port(s)Assignee: Gerald Pfeifer <gerald>
Status: Closed FIXED    
Severity: Affects Some People CC: agh, gerald, salvadore
Priority: --- Flags: salvadore: maintainer-feedback+
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
Update mono ${DATADIR} to correct version
none
Update mono release in run dependencies from 4.7.1 to 4.9.2
salvadore: maintainer-approval-
wine mono and gecko fixes salvadore: maintainer-approval-

Description Grzegorz Junka 2019-05-23 19:00:16 UTC
It actually fails to build when both GECKO and MONO options are set. I didn't test if the build also fails when only MONO is set but the build was successful when only GECKO was set.

Log:

=======================<phase: run-depends    >============================
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/gecko/wine_gecko-2.47-x86.msi - not found
===>   Installing existing package /packages/All/wine-gecko-devel-2.47.txz
[12rel0-gui-winetest-job-01] Installing wine-gecko-devel-2.47...
[12rel0-gui-winetest-job-01] Extracting wine-gecko-devel-2.47: ........ done
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/gecko/wine_gecko-2.47-x86.msi - found
===>   Returning to build of i386-wine-devel-4.0.r1_1,1
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/mono/wine-mono-4.7.1.msi - not found
===>   Installing existing package /packages/All/wine-mono-devel-4.8.3.txz
[12rel0-gui-winetest-job-01] Installing wine-mono-devel-4.8.3...
[12rel0-gui-winetest-job-01] Extracting wine-mono-devel-4.8.3: ...... done
===>   i386-wine-devel-4.0.r1_1,1 depends on file: /usr/local/share/wine/mono/wine-mono-4.7.1.msi - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/i386-wine-devel
=>> Cleaning up wrkdir
===>  Cleaning for i386-wine-devel-4.0.r1_1,1
build of emulators/i386-wine-devel | i386-wine-devel-4.0.r1_1,1 ended at Thu May 23 18:56:20 UTC 2019
build time: 00:00:18
!!! build failure encountered !!!
Comment 1 Alastair Hogge 2019-08-22 05:09:30 UTC
Created attachment 206776 [details]
Update mono ${DATADIR} to correct version
Comment 2 Alastair Hogge 2019-08-22 05:11:43 UTC
The ports still fails to compile with the ports tree at r509427. The problem is that emulators/i386-wine-devel is still looking for an older version of Mono. Submitted patch rectifies the problem.
Comment 3 Alastair Hogge 2019-08-22 07:52:14 UTC
Created attachment 206782 [details]
Update mono release in run dependencies from 4.7.1 to 4.9.2

Update patch to correct both emulators/i386-wine and emulators/i386-wine-devel
Comment 4 Rene Ladan freebsd_committer 2020-02-03 20:04:43 UTC
Maintainer reset.
Comment 5 Lorenzo Salvadore freebsd_committer 2020-02-08 21:29:31 UTC
(In reply to Alastair Hogge from comment #3)

Hi, I am the maintainer of i386-wine.

I will take a look at your patch in the next few days (maybe even tomorrow). Thanks for your work and your patience. And thanks for the bug reporter's patience as well.
Comment 6 Lorenzo Salvadore freebsd_committer 2020-02-09 11:11:02 UTC
Created attachment 211500 [details]
wine mono and gecko fixes

Much time has passed since the bug was reported and the patch provided, so things have changes.

Here is the actual situation:
- i386-wine and i386-wine-devel both work with the actual version of wine-mono-devel (now 4.9.4);
- i386-wine-devel is broken with respect to gecko.

Here is what the patch I propose does:
- fixes i386-wine-devel with respect to gecko;
- adopt wine-mono and wine-mono-devel, that are now without maintainers.
Comment 7 Gerald Pfeifer freebsd_committer 2020-02-09 17:10:01 UTC
I already have some (if not all) of these independently prepared on
my end; will work through these and of course with Lorenzo.
Comment 8 Lorenzo Salvadore freebsd_committer 2020-02-09 21:10:10 UTC
Comment on attachment 211500 [details]
wine mono and gecko fixes

Remove maintainer approval because there was an error in the patch and because we are doing things differently with Gerald.
Comment 9 Gerald Pfeifer freebsd_committer 2020-02-09 23:00:09 UTC
(In reply to Lorenzo Salvadore from comment #8)
> MAINTAINER=	dbn@FreeBSD.org

...does not feel right for emulators/i386-wine-devel/Makefile.inc ;
should this be you now, Lorenzo?

GECKO_RUN_DEPENDS I also have in my local tree and will commit per our
mail exchange.

On wine-mono{,-devel} we agreed that I'll take maintainership, and I have
some additional minor changes for each.


I'll work on those items over the next days.  Is there anything beyond
that, Lorenzo?


And thank you for your report and patience, Grzegorz!
Comment 10 Lorenzo Salvadore freebsd_committer 2020-02-09 23:37:18 UTC
(In reply to Gerald Pfeifer from comment #9)

Indeed, you spotted the error I was refering to in comment #8. This was probably caused by some confusion into my ports trees.

There is nothing more beyond that. Thanks Gerald.
Comment 11 Lorenzo Salvadore freebsd_committer 2020-02-09 23:38:14 UTC
(In reply to Lorenzo Salvadore from comment #10)

And to be 100% clear, yes that MAINTAINER should be me now :)
Comment 12 commit-hook freebsd_committer 2020-02-10 11:20:56 UTC
A commit references this bug:

Author: gerald
Date: Mon Feb 10 11:19:57 UTC 2020
New revision: 525701
URL: https://svnweb.freebsd.org/changeset/ports/525701

Log:
  Hand over maintainership to salvadore@ (from the vanilla ports@).

  Fix the optional dependency on emulators/wine-gecko-devel which is
  now at version 2.47.1.  This is the equivalent of revision 520954
  for emulators/i386-wine.

  PR:		238081

Changes:
  head/emulators/i386-wine-devel/Makefile.inc
Comment 13 Lorenzo Salvadore freebsd_committer 2020-02-10 22:31:15 UTC
(In reply to commit-hook from comment #12)

Thanks, Gerald.

Don't forget to close this PR: all problems with it are fixed now.
Comment 14 Gerald Pfeifer freebsd_committer 2020-02-10 22:55:05 UTC
(In reply to Lorenzo Salvadore from comment #13)
> Don't forget to close this PR: all problems with it are fixed now.

I was going to refer to it in some of the next commits, but indeed we
can close it now already.  One bug down. :)
Comment 15 commit-hook freebsd_committer 2020-02-12 11:00:35 UTC
A commit references this bug:

Author: gerald
Date: Wed Feb 12 11:00:20 UTC 2020
New revision: 525903
URL: https://svnweb.freebsd.org/changeset/ports/525903

Log:
  Assume maintainership, taking this from the ports@ pool.

  Fix the description which has been off (referring to HTML, probably
  coming from wine-gecko-devel) since r302265 on 2012-08-07.

  PR:		238081

Changes:
  head/emulators/wine-mono-devel/Makefile
Comment 16 commit-hook freebsd_committer 2020-02-15 08:47:48 UTC
A commit references this bug:

Author: gerald
Date: Sat Feb 15 08:47:11 UTC 2020
New revision: 526210
URL: https://svnweb.freebsd.org/changeset/ports/526210

Log:
  Backport r525903 | gerald | 2020-02-12 from wine-mono-devel:

    Assume maintainership, taking this from the ports@ pool.

    Fix the description which has been off (referring to HTML,
    probably coming from wine-gecko).

  PR:		238081

Changes:
  head/emulators/wine-mono/Makefile