Bug 238435

Summary: devel/py-apptools: Fix incorrect USES=python version spec
Product: Ports & Packages Reporter: vladimir.chukharev
Component: Individual Port(s)Assignee: Kai Knoblich <kai>
Status: Closed FIXED    
Severity: Affects Some People CC: kai
Priority: --- Flags: kai: merge-quarterly+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Patch vladimir.chukharev: maintainer-approval+

Description vladimir.chukharev 2019-06-09 12:50:10 UTC
Created attachment 204926 [details]
Patch

Remove limit on Python version.
Add USE_PYTHON=concurrent.
Reformat pkg-descr.
Comment 1 commit-hook freebsd_committer 2019-06-13 10:19:46 UTC
A commit references this bug:

Author: kai
Date: Thu Jun 13 10:19:36 UTC 2019
New revision: 504076
URL: https://svnweb.freebsd.org/changeset/ports/504076

Log:
  devel/py-apptools: Enable Python 3.x builds

  * Support for Python 3 was introduced with 4.4.0
  * Pet portlint (reduce the overall usage of lines in the pkg-descr and
    separate the USES block).
  * No bump of PORTREVISION due style changes only.

  PR:		238435
  Submitted by:	vladimir.chukharev@gmail.com (maintainer)
  MFH:		2019Q2

Changes:
  head/devel/py-apptools/Makefile
  head/devel/py-apptools/pkg-descr
Comment 2 Kai Knoblich freebsd_committer 2019-06-13 10:25:53 UTC
(In reply to vladimir.chukharev from comment #0)

Hi Vladimir,

thank you for the patch. I did a minor fix by removing the "concurrent" keyword because the port doesn't install scripts to ${PREFIX}/bin or documentation to ${DATADIR}:

> # pkg info -x apptools
> py27-apptools-4.4.0
> py36-apptools-4.4.0

Still waiting for the MFH approval from the ports-secteam to commit your changes to the 2019Q2 branch.
Comment 3 vladimir.chukharev 2019-06-13 10:39:09 UTC
(In reply to Kai Knoblich from comment #2)
Thanks a lot, Kai, particularly for explaining the meaning of PYTHON=concurrent in details. Now I need to double check my recent additions of it...
Comment 4 commit-hook freebsd_committer 2019-06-13 18:44:35 UTC
A commit references this bug:

Author: kai
Date: Thu Jun 13 18:43:31 UTC 2019
New revision: 504133
URL: https://svnweb.freebsd.org/changeset/ports/504133

Log:
  MFH: r504076

  devel/py-apptools: Enable Python 3.x builds

  * Support for Python 3 was introduced with 4.4.0
  * Pet portlint (reduce the overall usage of lines in the pkg-descr and
    separate the USES block).
  * No bump of PORTREVISION due style changes only.

  PR:		238435
  Submitted by:	vladimir.chukharev@gmail.com (maintainer)
  Approved by:	ports-secteam (miwi)

Changes:
_U  branches/2019Q2/
  branches/2019Q2/devel/py-apptools/Makefile
  branches/2019Q2/devel/py-apptools/pkg-descr
Comment 5 Kai Knoblich freebsd_committer 2019-06-13 18:48:17 UTC
(In reply to vladimir.chukharev from comment #3)

No worries, it was only a minor glitch.

All done here, committed to head and 2019Q2. Once again thank you for your patch!