Bug 238501

Summary: mail/dcc-dccd issue
Product: Ports & Packages Reporter: Max Kostikov <max>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Many People CC: pkubaj, ports-bugs
Priority: --- Flags: bugzilla: maintainer-feedback? (pkubaj)
Version: Latest   
Hardware: Any   
OS: Any   

Description Max Kostikov 2019-06-11 16:36:15 UTC
# service dccifd restart
dccifd not running? (check /var/run/dcc/dccifd.pid).
/usr/local/etc/rc.d/dccifd: WARNING: %D/libexec is not a directory.
Comment 1 Piotr Kubaj freebsd_committer 2019-06-11 17:42:08 UTC
This seems to be a regression in the whole ports tree.

E.g.:
root@talos:/usr/ports/www/firefox # make -V PLIST_SUB
 PYTHON_INCLUDEDIR=include/python2.7  PYTHON_LIBDIR=lib/python2.7  PYTHON_PLATFORM=freebsd13  PYTHON_SITELIBDIR=lib/python2.7/site-packages  PYTHON_SUFFIX=27  PYTHON_VER=2.7  PYTHON_VERSION=python2.7 PYTHON2="" PYTHON3="@comment " GTK2_VERSION="2.10.0"  GTK3_VERSION="3.0.0" OSREL=13.0 PREFIX=%D LOCALBASE=/usr/local  RESETPREFIX=/usr/local LIB32DIR=lib PERL_VERSION=5.28.2  PERL_VER=5.28  PERL5_MAN1=lib/perl5/site_perl/man/man1  PERL5_MAN3=lib/perl5/site_perl/man/man3  SITE_PERL=lib/perl5/site_perl  SITE_ARCH=lib/perl5/site_perl/mach/5.28 DOCSDIR="share/doc/firefox"  EXAMPLESDIR="share/examples/firefox"  DATADIR="share/firefox"  WWWDIR="www/firefox"  ETCDIR="etc/firefox"

Notice that there is PREFIX=%D.

CC'ing portmgr.
Comment 2 Antoine Brodin freebsd_committer 2019-06-11 17:47:21 UTC
I don't think this is a regression,  this has been like this since forever
Comment 3 Antoine Brodin freebsd_committer 2019-06-11 17:50:04 UTC
If there is a problem,  it's a bug in an individual port.
Comment 4 Antoine Brodin freebsd_committer 2019-06-11 17:52:02 UTC
Note the PLIST_SUB is different from SUB_LIST
Comment 5 Antoine Brodin freebsd_committer 2019-06-11 17:53:55 UTC
This line from the port is bogus:

SUB_LIST=      ${PLIST_SUB} WRKSRC=${WRKSRC} DCCHOME=${DCCHOME}
Comment 6 Piotr Kubaj freebsd_committer 2019-06-11 17:57:27 UTC
(In reply to Antoine Brodin from comment #5)
Yes, it's about this line, thanks!
Comment 7 commit-hook freebsd_committer 2019-06-14 07:17:33 UTC
A commit references this bug:

Author: pkubaj
Date: Fri Jun 14 07:17:02 UTC 2019
New revision: 504168
URL: https://svnweb.freebsd.org/changeset/ports/504168

Log:
  mail/dcc-dccd: fix startup scripts

  Fix startup scripts so that PREFIX is not %D.

  PR:		238501
  Approved by:	mat (mentor)
  Differential Revision:	https://reviews.freebsd.org/D20611

Changes:
  head/mail/dcc-dccd/Makefile
Comment 8 Piotr Kubaj freebsd_committer 2019-06-14 07:17:50 UTC
Thanks for reporting it, my server still runs old dcc so I didn't notice.