Bug 239139

Summary: graphics/mesa-dri 18.3.2_3: [mi] EQ overflowing. Additional events will be discarded until existing events are processed
Product: Ports & Packages Reporter: Martin Filla <freebsd>
Component: Individual Port(s)Assignee: freebsd-x11 mailing list <x11>
Status: Closed FIXED    
Severity: Affects Only Me CC: zeising
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
Xorg.0.log
none
xorg.conf none

Description Martin Filla 2019-07-11 09:43:44 UTC
Created attachment 205689 [details]
Xorg.0.log

[ 18673.317] (II) intel(0): Modeline "1920x1080"x0.0  140.00  1920 1968 2000 2096  1080 1083 1088 1113 -hsync -vsync (66.8 kHz eP)
(EE) [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
(EE) 
(EE) Backtrace:
(EE) 0: /usr/local/bin/X (mieqEnqueue+0x21f) [0x58a5df]
(EE) 1: /usr/local/bin/X (QueuePointerEvents+0x4b) [0x44ed4b]
(EE) 2: /usr/local/bin/X (xf86PostMotionEvent+0x113) [0x48add3]
(EE) 3: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x54ce) [0x80981252e]
(EE) 4: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x2662) [0x80980cb42]
(EE) 5: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x1cb8) [0x80980b218]
(EE) 6: /usr/local/bin/X (xf86AddEnabledDevice+0x58) [0x47c7a8]
(EE) 7: /usr/local/bin/X (xf86InstallSIGIOHandler+0x397) [0x4a0317]
(EE) 8: /lib/libthr.so.3 (_pthread_sigmask+0x536) [0x802624da6]
(EE) 9: /lib/libthr.so.3 (_pthread_getspecific+0xe12) [0x802624b82]
(EE) 10: ? (?+0xe12) [0x7fffffffffa5]
(EE) 11: /lib/libc.so.7 (__sys_sigprocmask+0xa) [0x802928b24]
(EE) 12: /lib/libthr.so.3 (_pthread_sigmask+0x51c) [0x802624d8c]
(EE) 13: /lib/libthr.so.3 (_pthread_getspecific+0xe12) [0x802624b82]
(EE) 14: ? (?+0xe12) [0x7fffffffffa5]
(EE) 15: /lib/libc.so.7 (ioctl+0xa) [0x80299cf84]
(EE) 16: /usr/local/lib/libdrm.so.2 (drmIoctl+0x2f) [0x801494f9f]
(EE) 17: /usr/local/lib/libdrm_intel.so.1 (drm_intel_bufmgr_gem_init+0x1a11) [0x8066a9981]
(EE) 18: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x865) [0x80643e1d5]
(EE) 19: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x819c) [0x80644d26c]
(EE) 20: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x1d8ad) [0x806477a1d]
(EE) 21: /usr/local/bin/X (miCopyRegion+0x3be) [0x5889de]
(EE) 22: /usr/local/bin/X (miDoCopy+0x31c) [0x588d3c]
(EE) 23: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x1da7e) [0x80647860e]
(EE) 24: /usr/local/bin/X (DamageReportDamage+0x1589) [0x527839]
(EE) 25: /usr/local/bin/X (SendGraphicsExpose+0x24d) [0x43413d]
(EE) 26: /usr/local/bin/X (UpdateCurrentTimeIf+0x297) [0x431b37]
(EE) 27: /usr/local/bin/X (remove_fs_handlers+0x5c7) [0x43b6b7]
(EE) 28: /usr/local/bin/X (_start+0x95) [0x425145]
(EE) 29: ? (?+0x95) [0x800836095]
(EE) 
(EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
(EE) [mi] mieq is *NOT* the cause.  It is a victim.
(EE) [mi] EQ overflow continuing.  100 events have been dropped.
(EE) 
(EE) Backtrace:
(EE) 0: /usr/local/bin/X (QueuePointerEvents+0x4b) [0x44ed4b]
(EE) 1: /usr/local/bin/X (xf86PostMotionEvent+0x113) [0x48add3]
(EE) 2: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x54ce) [0x80981252e]
(EE) 3: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x2662) [0x80980cb42]
(EE) 4: /usr/local/lib/xorg/modules/input/mouse_drv.so (_init+0x1cb8) [0x80980b218]
(EE) 5: /usr/local/bin/X (xf86AddEnabledDevice+0x58) [0x47c7a8]
(EE) 6: /usr/local/bin/X (xf86InstallSIGIOHandler+0x397) [0x4a0317]
(EE) 7: /lib/libthr.so.3 (_pthread_sigmask+0x536) [0x802624da6]
(EE) 8: /lib/libthr.so.3 (_pthread_getspecific+0xe12) [0x802624b82]
(EE) 9: ? (?+0xe12) [0x7fffffffffa5]
(EE) 10: /lib/libc.so.7 (__sys_sigprocmask+0xa) [0x802928b24]
(EE) 11: /lib/libthr.so.3 (_pthread_sigmask+0x51c) [0x802624d8c]
(EE) 12: /lib/libthr.so.3 (_pthread_getspecific+0xe12) [0x802624b82]
(EE) 13: ? (?+0xe12) [0x7fffffffffa5]
(EE) 14: /lib/libc.so.7 (ioctl+0xa) [0x80299cf84]
(EE) 15: /usr/local/lib/libdrm.so.2 (drmIoctl+0x2f) [0x801494f9f]
(EE) 16: /usr/local/lib/libdrm_intel.so.1 (drm_intel_bufmgr_gem_init+0x1a11) [0x8066a9981]
(EE) 17: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x865) [0x80643e1d5]
(EE) 18: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x819c) [0x80644d26c]
(EE) 19: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x1d8ad) [0x806477a1d]
(EE) 20: /usr/local/bin/X (miCopyRegion+0x3be) [0x5889de]
(EE) 21: /usr/local/bin/X (miDoCopy+0x31c) [0x588d3c]
(EE) 22: /usr/local/lib/xorg/modules/drivers/intel_drv.so (ignore+0x1da7e) [0x80647860e]
(EE) 23: /usr/local/bin/X (DamageReportDamage+0x1589) [0x527839]
(EE) 24: /usr/local/bin/X (SendGraphicsExpose+0x24d) [0x43413d]
(EE) 25: /usr/local/bin/X (UpdateCurrentTimeIf+0x297) [0x431b37]
(EE) 26: /usr/local/bin/X (remove_fs_handlers+0x5c7) [0x43b6b7]
(EE) 27: /usr/local/bin/X (_start+0x95) [0x425145]
(EE) 28: ? (?+0x95) [0x800836095]
(EE) 
[ 19199.127] [mi] Increasing EQ size to 1024 to prevent dropped events.
[ 19199.128] [mi] EQ processing has resumed after 163 dropped events.
[ 19199.128] [mi] This may be caused by a misbehaving driver monopolizing the server's resources.


pkg info graphics/mesa-dri
mesa-dri-18.3.2_3
Name           : mesa-dri
Version        : 18.3.2_3
Installed on   : Wed Jul 10 08:29:13 2019 CEST
Origin         : graphics/mesa-dri
Architecture   : FreeBSD:11:amd64
Prefix         : /usr/local
Categories     : graphics
Licenses       : 
Maintainer     : x11@FreeBSD.org
WWW            : http://www.mesa3d.org/
Comment        : OpenGL hardware acceleration drivers for DRI2+
Options        :
	VAAPI          : off
	VDPAU          : off
	WAYLAND        : on
Shared Libs required:
	libX11.so.6
	libxshmfence.so.1
	libexpat.so.1
	libLLVM-8.so
	libxcb-xfixes.so.0
	libwayland-client.so.0
	libXv.so.1
	libdrm_intel.so.1
	libxcb-present.so.0
	libunwind.so.8
	libX11-xcb.so.1
	libdrm_amdgpu.so.1
	libdrm.so.2
	libxcb-sync.so.1
	libxcb-dri3.so.0
	libxcb-randr.so.0
	libxcb.so.1
	libglapi.so.0
	libxcb-dri2.so.0
	libXvMC.so.1
	libdrm_radeon.so.1
Shared Libs provided:
	libvulkan_radeon.so
	libXvMCgallium.so.1
	libvulkan_intel.so
Annotations    :
	FreeBSD_version: 1102000
	repo_type      : binary
	repository     : FreeBSD
Flat size      : 29.2MiB
Description    :
This package contains the current stable release of the client drivers for DRI2+

With a X Server configured for DRI, they allow direct rendering of hardware-
accelerated OpenGL. This package also includes the software renderer, either
llvmpipe or classic SWrast.

WWW: http://www.mesa3d.org/
Comment 1 Jan Beich freebsd_committer 2019-07-11 22:05:39 UTC
Comment on attachment 205689 [details]
Xorg.0.log

> [    30.187] (--) PCI: (0:0:2:0) 8086:0116:1028:0571 rev 9, Mem @ 0xf2400000/4194304, 0xe0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/65536

0x0116 is HD Graphics 3000 (Sandy Bridge). Can you try graphics/drm-kmod? If it doesn't help keep drm-kmod but also try bug 236003 then add Option "AccelMethod" "SNA" to xorg.conf.

Alternatively, remove xf86-video-intel and switch to modesetting(4x) from xorg-server package.

> [    30.188] (--) PCI: (0:1:0:0) 10de:124d:1028:0571 rev 161, Mem @ 0xf0000000/33554432, 0xc0000000/268435456, 0xd0000000/67108864, I/O @ 0x00004000/128, BIOS @ 0x????????/65536

0x124d is GeForce GT 555M (Fermi). Did you install x11/nvidia-driver? If yes remove it as libGL from nvidia-driver may break i965 from mesa-dri. libglvnd yet to be supported on FreeBSD.
Comment 2 Martin Filla 2019-07-11 22:50:28 UTC
Created attachment 205705 [details]
xorg.conf

Now is ok  Xorg.0.log backtrace was maybe only at upgrade package. I added my xorg.conf.
Comment 3 Niclas Zeising freebsd_committer 2019-07-12 06:44:02 UTC
(In reply to Martin Filla from comment #2)
> Created attachment 205705 [details]
> xorg.conf
> 
> Now is ok  Xorg.0.log backtrace was maybe only at upgrade package. I added
> my xorg.conf.

Do you mean things are working as they should now?
Comment 4 Martin Filla 2019-07-12 16:18:23 UTC
I havent any backtrace in Xorg.logs and actual settings it works.
Comment 5 Niclas Zeising freebsd_committer 2019-07-29 12:31:47 UTC
Seems like everything is working as it should now.  Please re-open this if there's issues still.