Bug 239200

Summary: xorg -- no screens found, config OK
Product: Ports & Packages Reporter: meine <trialero>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed DUPLICATE    
Severity: Affects Many People CC: trialero, zeising
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   
Bug Depends on: 239065    
Bug Blocks:    
Description Flags
Xorg.0.log output with the error none

Description meine 2019-07-14 13:15:40 UTC
Created attachment 205762 [details]
Xorg.0.log output with the error

The recent update of Xorg (done on 20190713, latest version 7.7_3) gives an error that no screens are found:

vesa: Ignoring device with a bound kernel driver
Fatal server error:
(EE) no screens found(EE)

All settings worked well before the upgrade I did on July 13 2019, on a 64-bit system running FreeBSD 12.0-RELEASE-p7 GENERIC

Configuration files in /usr/local/etc/X11/xorg.conf.d/ are as described in the FreeBSD Handbook 5.4;

Main user is in the wheel and video group;

/boot/loader.conf contains `vesa_load="YES"';

xf86-driver-vesa is installed.

Changing settings to use and config the xf86-deriver-nv gives the same error.

Reinstalling the xorg software with `pkg install xorg' didn't resolve the problem.

Attached you'll find the output of /var/log/Xorg.0.log after starting x (startx).


Comment 1 meine 2019-07-15 17:04:12 UTC
in my bug report where I wrote xf86-driver_*, I mean:

Comment 2 meine 2019-07-29 19:46:26 UTC
downgrading libpciaccess form 0.14 to 0.13.5 resolved the problem on one of my machines, as being reported by some on the FreeBSD Forum [https://forums.freebsd.org/threads/x-no-screens-found-error.71293/page-3]

it seems that the bug I reported here has something to do with the bug on libpciaccess #239065


Comment 3 Niclas Zeising freebsd_committer 2019-07-29 20:08:23 UTC
This is a duplicate of 239065, can you add your information there?

*** This bug has been marked as a duplicate of bug 239065 ***