Bug 239578

Summary: net-mgmt/cacti: Update to 1.2.5
Product: Ports & Packages Reporter: Michael Muenz <m.muenz>
Component: Individual Port(s)Assignee: Kai Knoblich <kai>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: freebsd-ports, kai, matt
Priority: --- Flags: bugzilla: maintainer-feedback? (freebsd-ports)
Version: Latest   
Hardware: Any   
OS: Any   
URL: https://github.com/Cacti/cacti/blob/release/1.2.5/CHANGELOG
Attachments:
Description Flags
update to 1.2.5
none
updated patch to make diff clearer
none
update to 1.2.5 none

Description Michael Muenz 2019-08-01 13:01:59 UTC
Created attachment 206199 [details]
update to 1.2.5

Update to latest 1.2.5, also closes 238434.

The port version 1.2.3 has a known bug which prevents the wizard from finishing, so it's not possible to do a fresh install with the existing pkg on FreeBSD
Comment 1 Michael Muenz 2019-08-02 05:34:43 UTC
Created attachment 206217 [details]
updated patch to make diff clearer

Updated the patch to make it more readable compared to old pkg-plist, removed SNMP options from Makefile since not used anymore.

poudriere replaces cacti to %%CACTIUSER%% for db-sections (which was not on 1.2.3) but it doesn't do this for some files (which was in 1.2.3). I don't understand the logic here since it should be PORTNAME as those file will never be renamed when also someone decides it should run as another user.

I'm still new to ports building so bear with me if I ask stupid questions :)
Comment 2 Michael Muenz 2019-08-04 12:21:52 UTC
Created attachment 206271 [details]
update to 1.2.5

Removed SNMPBIN from Makefile and set a note in pkg message as suggested here:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238434
Comment 3 Kai Knoblich freebsd_committer 2019-08-15 21:53:38 UTC
Technically there's now a maintainer timeout but it's still holiday season at the moment and the maintainer is usually very active.

So let us wait for a few more days till the begin of next week.

The changelog since the 1.2.3 release contains a lot of bugfixes so it's also a MFH candidate.
Comment 4 Kai Knoblich freebsd_committer 2019-08-19 10:20:28 UTC
^Triage: Closing duplicate. Move any additional items/patches into bug #238434.

*** This bug has been marked as a duplicate of bug 238434 ***