Bug 239747

Summary: audio/rhythmbox Segmentation fault on launch (amd64)
Product: Ports & Packages Reporter: Anders Bolt-Evensen <andersbo87>
Component: Individual Port(s)Assignee: Joe Marcus Clarke <marcus>
Status: In Progress ---    
Severity: Affects Only Me CC: w.schwarzenfeld
Priority: --- Flags: w.schwarzenfeld: maintainer-feedback?
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
This file contains the full backtrace from LLDB none

Description Anders Bolt-Evensen 2019-08-09 17:01:29 UTC
Created attachment 206400 [details]
This file contains the full backtrace from LLDB

Hello!

Today I tried to install Rhythmbox onto my FreeBSD 12 system (amd64).
The installation itself was successful, but whenever I try to start the app, it crashes with a segmentation fault. When running lldb, I get the following information:

Process 83255 launching
Process 83255 launched: '/usr/local/bin/rhythmbox' (x86_64)
Process 83255 stopped
* thread #1, name = 'rhythmbox', stop reason = signal SIGSEGV: invalid address (fault address: 0x0)
    frame #0: 0x0000000801a5290c libc.so.7`strcmp + 60
libc.so.7`strcmp:
->  0x801a5290c <+60>: movq   0x8(%rdi), %rax
    0x801a52910 <+64>: addq   $0x8, %rdi
    0x801a52914 <+68>: movq   0x8(%rsi), %rdx
    0x801a52918 <+72>: addq   $0x8, %rsi

I've put the full backtrace in an attached file.

Not sure if it affects anyone else, so for now, I've put severity to "Affects Only Me"
Comment 1 Joe Marcus Clarke freebsd_committer 2019-09-02 14:49:20 UTC
I cannot reproduce on 12-STABLE with RB 3.4.2_6.

The backtrace points to a NULL string.  You may have a bad song in your library.  Can you try removing/moving ~/.local/share/rhythmbox and see if this crash goes away?
Comment 2 Anders Bolt-Evensen 2019-09-16 15:35:25 UTC
I've now tried removing ~/.local/share/rhythmbox, but the problem still exists. The stack trace is the same as in the original post.
I think my library was empty when I opened this report, but I removed the ~/.local/share/rhythmbox now to make sure it really is empty.