Bug 239875

Summary: devel/gradle: Update to 5.6
Product: Ports & Packages Reporter: Radim Kolar <hsn>
Component: Individual Port(s)Assignee: Tobias Kortkamp <tobik>
Status: Closed FIXED    
Severity: Affects Only Me CC: gasol.wu, pi
Priority: --- Keywords: needs-qa
Version: LatestFlags: tobik: maintainer-feedback-
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239903
Bug Depends on: 239900, 239901    
Bug Blocks:    
Attachments:
Description Flags
patch none

Description Radim Kolar 2019-08-15 13:45:26 UTC
Created attachment 206574 [details]
patch

tested and works
Comment 1 Tobias Kortkamp freebsd_committer 2019-08-15 14:57:17 UTC
(In reply to Radim Kolar from comment #0)
Did you also test that all consumers still build with Gradle 5.6?

biology/gatk
devel/ghidra
misc/elki
Comment 2 Kurt Jaeger freebsd_committer 2019-08-15 15:32:06 UTC
testbuilds for consumers@work
Comment 4 Radim Kolar 2019-08-16 10:35:46 UTC
I will try to build these. It looks like failure is caused by lack of network access on build server.
Comment 5 Kurt Jaeger freebsd_committer 2019-08-16 10:57:57 UTC
Please note that I tested using poudriere -- and poudriere by design has two phases: one to fetch all sources as listed in distinfo and one to build,
which *by design* does not have network access.
Comment 6 Tobias Kortkamp freebsd_committer 2019-08-16 11:05:24 UTC
Yes, Poudriere disallows network access during building, however
all of the now failing ports built fine with devel/gradle 5.0 even
without network access [1].

It looks like Gradle 5.6 wants to pull in additional things or cannot
find some of the provided dependencies now for some baffling reason.
How or why this happens now is what needs to be figured out.

[1] For reference:
http://beefy6.nyi.freebsd.org/data/120amd64-default/508805/logs/elki-0.7.1.1166.log
http://beefy6.nyi.freebsd.org/data/120amd64-default/508805/logs/gatk-4.1.2.0.43.log
http://beefy6.nyi.freebsd.org/data/120amd64-default/508805/logs/ghidra-9.0.4.log
Comment 7 commit-hook freebsd_committer 2019-11-20 09:51:54 UTC
A commit references this bug:

Author: tobik
Date: Wed Nov 20 09:51:44 UTC 2019
New revision: 517997
URL: https://svnweb.freebsd.org/changeset/ports/517997

Log:
  Create devel/gradle5 in preparation of devel/gradle update

  Many consumers fail to build with newer Gradle versions.

  PR:		239875, 239900, 239901, 239902

Changes:
  head/biology/gatk/Makefile
  head/devel/Makefile
  head/devel/ghidra/Makefile
  head/devel/gradle5/
  head/devel/gradle5/Makefile
  head/devel/gradle5/pkg-plist
  head/misc/elki/Makefile
Comment 8 commit-hook freebsd_committer 2019-11-20 10:23:59 UTC
A commit references this bug:

Author: tobik
Date: Wed Nov 20 10:23:05 UTC 2019
New revision: 517999
URL: https://svnweb.freebsd.org/changeset/ports/517999

Log:
  devel/gradle: Update to 6.0.1

  - Assign to myself

  Changes:	https://docs.gradle.org/6.0.1/release-notes.html
  PR:		239875
  Submitted by:	Radim Kolar <hsn@sendmail.cz> (update to 5.6)
  Approved by:	gasol.wu@gmail.com (maintainer timeout, 3 months)

Changes:
  head/devel/gradle/Makefile
  head/devel/gradle/distinfo
  head/devel/gradle/pkg-plist