Bug 239876

Summary: FreeBSD-12.0-RELEASE-amd64-bootonly.iso fails w/ mountroot() error 19 in UEFI
Product: Base System Reporter: Rick <vrwmiller>
Component: miscAssignee: freebsd-bugs mailing list <bugs>
Status: New ---    
Severity: Affects Some People CC: ggm
Priority: ---    
Version: 12.0-RELEASE   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
screenshot of bootonly iso failure
none
mini-memdisk boot failure snapshot none

Description Rick 2019-08-15 13:58:24 UTC
FreeBSD-12.0-RELEASE-amd64-bootonly.iso fails to boot in UEFI over http citing mountroot error 19. ISO is PXE booted from a network server. Hardware is HP DL360G9, dual E5-2640v4 2.6GHz, 128GB RAM

Reproduced by:

* Power on system
* Press F12 to boot to network, which sends ISO to host
* Allow Beastie countdown to expire

Expected results are that ISO continues to boot permitting manual OS installation.

This has been reported for numerous releases via bug #227808, bug #199197, bug #179312, bug #169919
Comment 1 Rick 2019-08-15 13:59:24 UTC
Created attachment 206575 [details]
screenshot of bootonly iso failure
Comment 2 Rick 2019-08-15 14:28:11 UTC
Created attachment 206576 [details]
mini-memdisk boot failure snapshot

This attachment illustrates a similar error with the mini-memstick img
Comment 3 George Michaelson 2019-10-03 02:57:42 UTC
Dell R710 has this problem.

Dell R730 has this problem.

reset BIOS boot, problem went away. Installed BIOS+UEFI to ensure disk has 200mb region for future fix.

Have a machine I can test on, if useful. I can reproduce this at will.