Bug 240409

Summary: [NEW PORT] lang/julia12: Julia Language: A fresh approach to technical computing
Product: Ports & Packages Reporter: Iblis Lin <iblis.dif01>
Component: Individual Port(s)Assignee: Li-Wen Hsu <lwhsu>
Status: In Progress ---    
Severity: Affects Only Me CC: iblis.dif01, lwhsu, rene
Priority: --- Keywords: feature, needs-patch
Version: LatestFlags: koobs: maintainer-feedback? (iblis.dif01)
Hardware: Any   
OS: Any   
URL: https://github.com/JuliaLang/julia/blob/backports-release-1.2/NEWS.md#julia-v12-release-notes
Attachments:
Description Flags
lang/julia12 patches none

Description Iblis Lin 2019-09-08 08:30:11 UTC
Created attachment 207276 [details]
lang/julia12 patches

Changelog is here:
  https://github.com/JuliaLang/julia/blob/backports-release-1.2/NEWS.md#julia-v12-release-notes


This patches includes:
  - proper modification to the meta port `lang/julia`
  - minor changes in lang/julia06 and lang/julia07

Poudriere testport:
  - passed on FreeBSD 12.0-RELEASE amd64 with default OPTIONS
  - passed on FreeBSD 12.0-RELEASE amd64 with OPENLIBM enabled
  - passed on FreeBSD 12.0-RELEASE amd64 with OPENBLAS enabled
  - passed on FreeBSD 12.0-RELEASE amd64 with all OPTIONS enabled

  - passed on FreeBSD 12.0-RELEASE i386  with default OPTIONS
  - passed on FreeBSD 12.0-RELEASE i386  with OPENLIBM enabled
  - passed on FreeBSD 12.0-RELEASE i386  with OPENBLAS enabled
  - passed on FreeBSD 12.0-RELEASE i386  with all OPTIONS enabled
Comment 1 Li-Wen Hsu freebsd_committer 2019-09-08 09:44:14 UTC
Are you sure that we need to add one more version of Julia?
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2019-09-08 10:06:14 UTC
Should separate patches for the new port and the lang/julia 1.0.4 update into separate issues and have this one depend on the latter if the new port is based off the existing port update
Comment 3 Iblis Lin 2019-09-08 15:27:52 UTC
(In reply to Li-Wen Hsu from comment #1)
yeah, since Julia v1.1 doesn't reach the end of life, I want to add a new port for v1.2.
Comment 4 Iblis Lin 2019-09-08 15:31:08 UTC
(In reply to Kubilay Kocak from comment #2)

hmm, there are some options listed in lang/julia requires the existence of lang/julia12 (this new port).
I think it's not easy to read/check if I split this patch into two parts.
Comment 5 Li-Wen Hsu freebsd_committer 2019-09-10 11:07:55 UTC
Maintainer is checking issues on 11.3.
Comment 6 Li-Wen Hsu freebsd_committer 2019-11-01 10:52:17 UTC
Any update on this one? If is has no issues on 12, we can mark 11 as IGNORE first.
Comment 7 Iblis Lin 2019-11-03 05:43:42 UTC
The issue is same as https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235891.
If user has a newer ld, the error will be popped up.
Comment 8 Rene Ladan freebsd_committer 2020-12-30 12:17:00 UTC
lang/julia10 (the current LTS according to https://julialang.org/downloads/ ) hinges on Python 2.7 so will be removed tomorrow, it might be worthwhile to update this port to 1.5.3 (the latest non-LTS) or create a lang/julia15 instead of lang/julia10? That is, if it uses Python 3.6+