Bug 241207

Summary: net-mgmt/p5-FusionInventory-Agent: Update to 2.5.2
Product: Ports & Packages Reporter: Boris Korzun <drtr0jan>
Component: Individual Port(s)Assignee: Alexey Dokuchaev <danfe>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: danfe, freebsd, ohartmann
Priority: --- Keywords: needs-patch, needs-qa
Version: LatestFlags: bugzilla: maintainer-feedback? (freebsd)
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Update the FusionInventory Agent to 2.5.1
none
Update the FusionInventory Agent to 2.5.1
none
Update the FusionInventory Agent to 2.5.1
none
Update the FusionInventory Agent to 2.5.2 none

Description Boris Korzun 2019-10-12 06:12:42 UTC
Created attachment 208254 [details]
Update the FusionInventory Agent to 2.5.1

Hi,

there's a patch for updating p5-FusionInventory-Agent to 2.5.1 in the attachment.

Changes:
* Version bump (from 2.4 to 2.5.1).
* Changed MASTER_SITES from CPAN to GitHub. There's not a 2.5.1 stable version on the CPAN (only 2.5).
* Removal DAEMON option. Couldn't use RC_SUBR script with DAEMON=OFF. The option depends moved to main depends.
* Added p5-Net-Ping to BUILD depends. Needed for Deploy (2.3.18) and NetDiscovery (2.4.2).
* Added p5-Thread-Queue to BUILD depends. Needed for NetDiscovery/NetInventory (2.3.15).
* Added p5-XML-XPath to BUILD depends. Needed for HTTP daemon plugin (2.5.1).
* Changed dmidecode version depends.
* Removal nmap depends (2.4.1).
* Removal obsolete depends.
* Removal obsolete conflits.
* Added fusioninventory-remoteinventory to plist (2.5).
* Added HTTP daemon plugins to plist (2.5).
* Changed options in plist.

Best regards
Boris
Comment 1 Mathieu Simon 2019-10-21 05:57:16 UTC
Hi Boris

Thanks for the patch and your patience, I've been quite busy recently and was unable to get back to you.

There are a couple of minor things I'd like to work out before I'd like to giving my thumbs up on your patch such as (but not all):

* If we switch to github we might as well use the specific macros in the ports tree (it should spare us using long URLs)
* You've removed i.e. %DEPLOY% (unfortunately they get lost if you simply regenerate the distinfo)

To be honest, it's been a long time since I've used Fusioninventory in daemon mode on FreeBSD - good catch on finding issues in that area. If it doesn't work, we should drop it I'd say.

I'll give it a whirl in my newly-built poudriere environment and share a follow-up.

-- Mathieu
Comment 2 Boris Korzun 2019-10-21 12:04:44 UTC
Created attachment 208481 [details]
Update the FusionInventory Agent to 2.5.1

Hi Mathieu,

Okay, I've used the specific macros.
But I had not removed %DEPLOY%.

I had removed %DAEMON% as meaningless. If RC_SUBR exists (it isn't switched), it's not allowed to compile the Fusioninventory without daemon support. The %DAEMON% option SHOULD be enabled permanently.

Best regards
Boris
Comment 3 Boris Korzun 2019-10-21 12:07:39 UTC
Created attachment 208482 [details]
Update the FusionInventory Agent to 2.5.1
Comment 4 Boris Korzun 2019-12-31 05:32:38 UTC
Created attachment 210346 [details]
Update the FusionInventory Agent to 2.5.2

Hi,

there's a patch for updating p5-FusionInventory-Agent to 2.5.2 in the attachment.

Changes:
* Version bump (from 2.4 to 2.5.2).
* Changed MASTER_SITES from CPAN to GitHub. There's no a 2.5.2 stable version on the CPAN (only 2.5).
* Removal DAEMON option. Couldn't use RC_SUBR script with DAEMON=OFF. The option depends moved to main depends.
* Added p5-Module-Install to BUILD depends.
* Added p5-Net-Ping to BUILD depends. Needed for Deploy (2.3.18) and NetDiscovery (2.4.2).
* Added p5-Thread-Queue to BUILD depends. Needed for NetDiscovery/NetInventory (2.3.15).
* Added p5-XML-XPath to BUILD depends. Needed for HTTP daemon plugin (2.5.1).
* Added p5-YAML-Tiny to BUILD depends.
* Changed dmidecode version depends.
* Removal nmap depends (2.4.1).
* Removal obsolete depends.
* Removal obsolete conflits.
* Added fusioninventory-remoteinventory to plist (2.5).
* Added HTTP daemon plugins to plist (2.5).
* Changed options in plist.

Best regards
Boris
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2019-12-31 05:38:25 UTC
*** Bug 242477 has been marked as a duplicate of this bug. ***
Comment 6 Alexey Dokuchaev freebsd_committer 2020-07-06 12:50:00 UTC
Port was updated to version 2.5.2 in the ports r536668.