Bug 241291

Summary: x11-wm/xfce4-wm: After pkg upgrade XFCE Suspend Does Not Complete When Click "Suspend" Prior to Suspend Default Delay Time of 30 Seconds
Product: Ports & Packages Reporter: John <jlmales>
Component: Individual Port(s)Assignee: freebsd-xfce (Nobody) <xfce>
Status: New ---    
Severity: Affects Many People Flags: bugzilla: maintainer-feedback? (xfce)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Description Flags
Console when system was booted days prior to 12 October 2019 14:45+000 FreeBSD Upgrade and the Upgrade Leading to Bug none

Description John 2019-10-16 01:48:17 UTC
Created attachment 208360 [details]
Console when system was booted days prior to 12 October 2019 14:45+000 FreeBSD Upgrade and the Upgrade Leading to Bug

This issue is being logged against x11-wm/xfce4-wm as it was the only XFCE port item that was updated  via the "pkg upgrade" of 12 October 2019 14:58+000 UTC.

bug #241267 was still in play.

For the first time since the "pkg upgrade" of 12 October 2019 14:58+000 UTC (due to as yet unreported bug) I selected the XFCE "Suspend" 15 October 2019 19:35:18+0000 UTC.  XFCE presented the usual Dialogue widget "Suspend" "Do you want to suspend to RAM?" "Suspending computer in xx seconds" where the "xx" started at 30 and only reached 29 due to my using the mouse to click the "Suspend" button of the Dialogue widget and not the "Cancel" button.

After 2 minutes the system had still not suspended.  The XFCE clock displayed "2019-10-15 19:35:19+0000 UTC" (the one second took to click "suspend button) per the customized date format configured just after installing XFCE mid July 2019.  "xx" was still 29 and the XFCE "Suspend" Dialogue widget as noted above was still displayed as well as the XFCE DE behind the "Suspend" Dialogue widget.  The mouse was still active, but the XFCE DE and "Suspend" Dialogue widget were not responsive (expected behaviour for suspend in progress) to any mouse click action.

CRTL-ALT-F2 presented VTTY2 as expected.  CTRL-ALT-F9 returned to the above noted XFCE DE, "Suspend" Dialogue widget, "xx" still at 29, mouse responsive, no responsive mouse clicks to XFCE DE nor "Suspend" Dialogue widget.

I tried to use scrot on VTTY2 to capture the stated of the XFCE DE as noted above.  scrot would not allow from VTTY2 as there was no X Session active on VTTY2.  I was not able to take any pics due to long standing issues with SD cards in my phone.

I left the system in the above noted XFCE DE state, Suspend" Dialogue widget, et al as I had to go out.

On my return 16 October 2019 00:50+0000 UTC (5.5 hours late) the system state as noted above, XFCE time displayed of "2019-10-15 19:35:19+0000 UTC", "xx still 29, et al remained.  The system had not even blanked the screen

At 16 October 2019 00:55+0000 UTC the xfce4-screensaver (currently configured for while back active) blanked the screen and bug #241219 presented itself.  Through some possible keyboard actions I know from testing bug #241219 I was able to return to the previous XFCE DE state, Suspend" Dialogue widget, et al as noted including mouse state as noted still same.

I changed to VTTY2 and issued a "sudo reboot"  During the shutdown one CLI message appeared in red to effect of XORG error, but there was no time to copy down the message and even if I the SD card issues of my phone did not exist it is likely I not even have time to take a pic of this XOrg error message and other messages that may be related.

FreeBSD 11.3 and XFCE were installed mid July 2019 with no problems nor issues in use of XFCE DE until the "pkg upgrade" of 12 October 2019 14:58+000 UTC.  The last "pkg upgrade" done was 02 October 2019 0326+000 UTC and presented no issue with the XFCE DE as had been case and expected since the install of mid July 2019.
Comment 1 John 2019-10-16 16:37:30 UTC
At 16 October 2019 06:12:36 I used the XFCE DE "Suspend" function.  I did not click the "Suspend" button until the countdown time in the "Suspend" Dialogue widget reached 23 seconds.

bug #241267 was not in play for this XFCE session.

Other than only allowing 5 minutes from time the XFCE clock froze (expected as part of suspend process) at "2019-10-16 06:21:43+0000 UTC" the bug as described occurred and again using "poweroff", but this time as root on VTTY2.
Comment 2 John 2020-09-13 02:10:29 UTC
This bug is still ongoing despite number of times XFCE has been updated to date.  FreeBSD system is current of 08 September 202 and "pkg update" as of this bug update still indicated system is up to date 9since 08 September 2020)"