Bug 241755

Summary: mail/py-pyspf: 2.0.13 is broken; patch provided
Product: Ports & Packages Reporter: Kamigishi Rei <spambox>
Component: Individual Port(s)Assignee: Sunpoet Po-Chuan Hsieh <sunpoet>
Status: Closed FIXED    
Severity: Affects Only Me CC: paul.le.gauret
Priority: --- Flags: koobs: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch-spf.py none

Description Kamigishi Rei 2019-11-06 12:09:58 UTC
Created attachment 208909 [details]
patch-spf.py

The 2.0.13 release of pyspf has a bug that is already fixed in the source but 2.0.14 is not ready for release yet.

Nov  6 11:58:14 mail policyd-spf[96439]: Traceback (most recent call last):
(skip)
Nov  6 11:58:14 mail policyd-spf[96439]: NameError: name 'strict' is not defined
(skip)
Nov  6 11:58:14 mail postfix/smtpd[88968]: NOQUEUE: reject

Attached patch fixes the issue.
Comment 1 commit-hook freebsd_committer 2019-11-13 23:48:30 UTC
A commit references this bug:

Author: sunpoet
Date: Wed Nov 13 23:47:39 UTC 2019
New revision: 517539
URL: https://svnweb.freebsd.org/changeset/ports/517539

Log:
  Restore DNSLookup API for pydnsv(DNS) for tcp fallback works again

  - Bump PORTREVISION for package change

  PR:		241755
  Submitted by:	Kamigishi Rei <spambox@haruhiism.net>
  Obtained from:	https://github.com/sdgathman/pyspf/commit/4744deeec4a2c10987aae72989d7137156ed4151

Changes:
  head/mail/py-pyspf/Makefile
  head/mail/py-pyspf/files/patch-spf.py
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-11-13 23:48:33 UTC
Committed. Thanks!
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-11-18 18:24:17 UTC
*** Bug 241991 has been marked as a duplicate of this bug. ***