Bug 241768

Summary: Serial port hang on Raspberry PI arm64
Product: Base System Reporter: ian
Component: armAssignee: freebsd-arm (Nobody) <freebsd-arm>
Status: Closed Feedback Timeout    
Severity: Affects Many People CC: emaste, mhorne
Priority: ---    
Version: 12.0-STABLE   
Hardware: arm64   
OS: Any   

Description ian 2019-11-07 00:10:33 UTC
If data is sent to the raspberry pi serial port immediately after boot and before any data is output the serial port will often hang up completely. Attempts to output will stall. No input can be received. If anything is output before the first data is received by the port it all works fine.

In all my tests one character is received, after this nothing more can be input or output.
Comment 1 Ed Maste freebsd_committer 2019-11-14 21:31:03 UTC
Are you certain this isn't a problem with earlier boot stages (before FreeBSD even starts booting)?
Comment 2 Mitchell Horne freebsd_committer 2021-01-11 18:22:11 UTC
Closing, enough time has passed without feedback or further information.

If it can be confirmed that the problem is caused by FreeBSD, and is present in a currently supported release, please re-open the issue.