Bug 242297

Summary: devel/meson: update to 0.52.1
Product: Ports & Packages Reporter: Jan Beich <jbeich>
Component: Individual Port(s)Assignee: Port Management Team <portmgr>
Status: Closed FIXED    
Severity: Affects Only Me CC: gnome
Priority: --- Keywords: needs-qa
Version: LatestFlags: bugzilla: maintainer-feedback? (gnome)
jbeich: exp-run?
Hardware: Any   
OS: Any   
URL: https://github.com/mesonbuild/meson/compare/0.52.0...0.52.1
Bug Depends on: 241105    
Bug Blocks: 243202    
Attachments:
Description Flags
v1 none

Description Jan Beich freebsd_committer 2019-11-29 15:37:48 UTC
Created attachment 209528 [details]
v1

See URL for upstream changes.
Comment 3 Jan Beich freebsd_committer 2019-12-03 20:10:34 UTC
I can't reproduce locally comment 1 and comment 2. "Host OSVERSION: 1300049" is ~1 month old, consider updating kernel then retry. According to signal(3) SIGSYS is sent when "non-existent system call invoked".
Comment 4 Jan Beich freebsd_committer 2019-12-03 20:30:00 UTC
Nothing depends on devel/gnome-builder, so it can be left broken on landing to see what happens on the package builders. Debugging requires running ktrace(1) on the affected kernel to figure out syscall number and why it ended up being used in a jail for old -RELEASE. Unfortunately, I don't have time to reproduce outside of poudriere by booting old FreeBSD releases or -CURRENT snapshots in a VM.
Comment 5 Antoine Brodin freebsd_committer 2019-12-06 08:36:20 UTC
(In reply to Jan Beich from comment #3)
which version of head are you using?
Comment 6 Jan Beich freebsd_committer 2019-12-06 11:55:31 UTC
base r355439 kernel/world, recently updated but still can't reproduce. Even with dependencies from pkg.freebsd.org I can't reproduce.

- 12.0 amd64: https://reviews.freebsd.org/P338
- 12.0 i386:  https://reviews.freebsd.org/P337
Comment 7 Antoine Brodin freebsd_committer 2019-12-06 12:10:43 UTC
(In reply to Jan Beich from comment #6)
I may have found the issue,  CLUSTER13 kernel is missing COMPAT_FREEBSD12...
Comment 8 commit-hook freebsd_committer 2019-12-07 18:20:58 UTC
A commit references this bug:

Author: jbeich
Date: Sat Dec  7 18:20:20 UTC 2019
New revision: 519227
URL: https://svnweb.freebsd.org/changeset/ports/519227

Log:
  devel/meson: update to 0.52.1

  Changes:	https://github.com/mesonbuild/meson/compare/0.52.0...0.52.1
  PR:		242297
  Exp-run by:	antoine

Changes:
  head/devel/meson/Makefile
  head/devel/meson/distinfo