Bug 242757

Summary: multimedia/kodi-devel: crash on startup
Product: Ports & Packages Reporter: rozhuk.im
Component: Individual Port(s)Assignee: Tobias Kortkamp <tobik>
Status: Closed Unable to Reproduce    
Severity: Affects Only Me CC: rozhuk.im
Priority: --- Flags: bugzilla: maintainer-feedback? (tobik)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
kodi-devel.diff none

Description rozhuk.im 2019-12-21 04:51:30 UTC
Not always, first run ok, but on 2-3 run got crush:

Core was generated by `/usr/local/lib/kodi/kodi-x11'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000000000 in ?? ()
[Current thread is 1 (LWP 102297)]
(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x00000008053195b0 in fnmatch () from /lib/libc.so.7
#2  0x0000000801baed20 in get_subsystem_config_by_syspath (path=0x7fffdf3f5ee0 "/dev/pass2") at udev-utils.c:142
#3  0x0000000801baec75 in get_subsystem_by_syspath (syspath=0x7fffdf3f5ee0 "/dev/pass2") at udev-utils.c:169
#4  0x0000000801bab585 in udev_filter_match (udev=0x8139a9690, ufh=0x81dc89a58, syspath=0x7fffdf3f5ee0 "/dev/pass2") at udev-filter.c:128
#5  0x0000000801bab288 in enumerate_cb (path=0x7fffdf3f5ee0 "/dev/pass2", type=2, arg=0x81dc89a50) at udev-enumerate.c:180
#6  0x0000000801baffa4 in scandir_sub (path=0x7fffdf3f5ee0 "/dev/pass2", off=10, rem=69, ctx=0x7fffdf3f5ec8) at utils.c:252
#7  0x0000000801bafddb in scandir_recursive (path=0x7fffdf3f5ee0 "/dev/pass2", len=80, ctx=0x7fffdf3f5ec8) at utils.c:269
#8  0x0000000801bab1b1 in udev_enumerate_scan_devices (ue=0x81dc89a50) at udev-enumerate.c:203
#9  0x0000000000b48e2d in CUDevProvider::GetDisks(std::__1::vector<CMediaSource, std::__1::allocator<CMediaSource> >&, bool) ()
#10 0x0000000000eef7a0 in CMediaManager::GetRemovableDrives(std::__1::vector<CMediaSource, std::__1::allocator<CMediaSource> >&) ()
#11 0x00000000016d06d5 in XFILE::CSourcesDirectory::GetDirectory(CURL const&, CFileItemList&) ()
#12 0x000000000169563c in XFILE::CDirectory::GetDirectory(CURL const&, std::__1::shared_ptr<XFILE::IDirectory>, CFileItemList&, XFILE::CDirectory::CHints const&) ()
#13 0x00000000016951c7 in XFILE::CDirectory::GetDirectory(CURL const&, CFileItemList&, XFILE::CDirectory::CHints const&) ()
#14 0x00000000016950af in XFILE::CDirectory::GetDirectory(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, CFileItemList&, std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, int) ()
#15 0x0000000000f48ceb in CDirectoryJob::DoWork() ()
#16 0x0000000000e6807f in CJobWorker::Process() ()
#17 0x0000000000eed055 in CThread::Action() ()
#18 0x0000000000eed3ca in ?? ()
#19 0x000000080524975b in ?? () from /lib/libthr.so.3
#20 0x0000000000000000 in ?? ()
Backtrace stopped: Cannot access memory at address 0x7fffdf3f7000


On same desktop kodi that build from sources without port system - not crash. I'm not sure how long time ago this starts.
I try build kodi without all options and without all patches from /files and PATCHFILES from Makefile - not help.

On another system kodi-devel-19.0.a20191112 - ok. Probably this last good version.
Comment 1 Tobias Kortkamp freebsd_committer 2019-12-21 10:02:43 UTC
Created attachment 210095 [details]
kodi-devel.diff

(In reply to rozhuk.im from comment #0)
I cannot reproduce no matter how often I restart Kodi.  I'm afraid you'll have
to start bisecting between f6311e3c5559ced201fb8ff91846fe4b9b668a9a and
c35b70cc2c5618f114ebea905aaacfe96eb15951 to find out which upstream commit
broke it.

OTOH it seems like this could be a bug in vanilla devel/libudev-devd.  I'm
using a slightly patched version of that port [1], so try updating it.

Alternatively, the attached patch adds a UDEV option to kodi-devel, try building
with it disabled and see if it is any better.

[1] https://github.com/t6/freebsd-ports-sndio/commit/69c67d86dc1a584df906ed599023ffa3fb9e4823.patch
Comment 2 Tobias Kortkamp freebsd_committer 2020-01-18 08:19:52 UTC
Closing since I'm unable to reproduce or get additional feedback.