Bug 243112

Summary: graphics/drm-kmod: g20190710 doesn't recognize HDMI head on RV730 XT [Radeon HD 4670]
Product: Ports & Packages Reporter: Zeus Panchenko <zeus.panchenko>
Component: Individual Port(s)Assignee: freebsd-x11 (Nobody) <x11>
Status: New ---    
Severity: Affects Only Me CC: x11, zeising
Priority: --- Flags: linimon: maintainer-feedback? (x11)
Version: Latest   
Hardware: i386   
OS: Any   

Description Zeus Panchenko 2020-01-05 11:01:45 UTC
graphics/drm-kmod-g20190710 doesn't recognize HDMI head on RV730 XT Radeon HD 4670 (xrandr reports HDMI as disconnected)

while graphics/drm-legacy-kmod-g20191217 works fine

> uname -a
12.1-RELEASE-p1

> pciconf -lv
vgapci0@pci0:2:0:0:	class=0x030000 card=0x02761043 chip=0x94901002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'RV730 XT [Radeon HD 4670]'
    class      = display
    subclass   = VGA
Comment 1 Niclas Zeising freebsd_committer 2020-01-07 09:05:25 UTC
graphics/drm-kmod is just a meta-port that pulls in the correct drm-*-kmod, can you list the version of the installed drm-fbsd12.0-kmod please?
Comment 2 Zeus Panchenko 2020-01-07 09:46:17 UTC
drm-fbsd12.0-kmod-4.16.g20191120

as well as all variants of ports in head

in addition, I've checked it on 13.0-CURRENT and ports head, so, all variants except legacy behave the same - after drm initialization, HDMI display blanks (though, it doesn't show "No signal" message in that state)
Comment 3 Niclas Zeising freebsd_committer 2020-09-17 09:52:21 UTC
Is this still relevant after the update of drm-current-kmod in current?