Bug 243210

Summary: make lang/go-devel for aarch64
Product: Ports & Packages Reporter: Igor Konov <montblanc>
Component: Individual Port(s)Assignee: Dmitri Goutnik <dmgk>
Status: Closed Works As Intended    
Severity: Affects Only Me CC: wcarson.bugzilla
Priority: --- Flags: bugzilla: maintainer-feedback? (dmgk)
Version: Latest   
Hardware: Any   
OS: Any   

Description Igor Konov 2020-01-09 10:17:08 UTC
15 Nov 2019: lang/go-devel: Add support for aarch64

But make fails.

cmd/link/internal/sym
cmd/link/internal/loader
cmd/link/internal/objfile
cmd/link/internal/loadelf
cmd/link/internal/loadmacho
cmd/link/internal/loadpe
cmd/link/internal/loadxcoff
cmd/link/internal/ld
cmd/link/internal/amd64
cmd/link/internal/arm
cmd/link/internal/arm64
cmd/link/internal/mips
cmd/link/internal/mips64
cmd/link/internal/ppc64
cmd/link/internal/riscv64
cmd/link/internal/s390x
cmd/link/internal/wasm
cmd/link/internal/x86
cmd/link
go build cmd/compile/internal/ssa: /var/ports/sharedfs/usr/ports/lang/go-devel/work/go-a5bfd9da1d1b24f326399b6b75558ded14514f23/pkg/tool/freebsd_arm64/compile: signal: killed
go tool dist: FAILED: /var/ports/sharedfs/usr/ports/lang/go-devel/work/go-a5bfd9da1d1b24f326399b6b75558ded14514f23/pkg/tool/freebsd_arm64/go_bootstrap install -gcflags=all= -ldflags=all= -v -i cmd/asm cmd/cgo cmd/compile cmd/link: exit status 1
*** Error code 2

Stop.
make: stopped in /sharedfs/usr/ports/lang/go-devel
Comment 1 Tobias Kortkamp freebsd_committer 2020-01-09 10:32:18 UTC
Port builds fine: http://thunderx1.nyi.freebsd.org/data/113arm64-quarterly/522068/logs/go-devel-g20191217.log

> signal: killed

Are you running out of memory?
Comment 2 Igor Konov 2020-01-09 12:56:05 UTC
(In reply to Tobias Kortkamp from comment #1)

Stopped all services and processes.
The error remained.
Paspberry Pi 3 / RAM 1 GB.
Comment 3 Dmitri Goutnik freebsd_committer 2020-01-09 22:44:53 UTC
(In reply to Igor Konov from comment #2)
No, just 1GB of RAM is not enough. I'm able to build on RPi3 with 1GB RAM + 2GB swap.
Comment 4 wcarson.bugzilla 2020-02-04 22:20:02 UTC
(In reply to Dmitri Goutnik from comment #3)

I have been struggling to build lang/go-devel on my RPi 3B+ with 1 GB RAM, 4 GB swap, and vm.pfault_oom_attempts=-1 using poudriere since ~Jan 22 (first attempt at go-devel-g20191217_1). I see the following message in /var/log/messages:

Feb  4 21:40:38 ports02 kernel: pid 44857 (compile), jid 3, uid 65534, was killed: out of swap space

However, monitoring the swap usage via swapinfo, the build never actually seems to consume any. In comment #3 you suggest that you were able to successfully build the port with less swap than I have. I'm curious if you have any other settings that might have enabled this?

I would appreciate any insight you could provide.
Comment 5 wcarson.bugzilla 2020-02-05 16:54:30 UTC
(In reply to wcarson.bugzilla from comment #4)

Switching from a 4GB swap _file_ to a 2GB swap _partition_ I was able to successfully build go-devel-g20191217_1 on my RPi3.