Bug 243485

Summary: databases/mysql57-server: Cannot build 5.7.29 if devel/boost-libs port is installed
Product: Ports & Packages Reporter: Ted Milker <tmilker+freebsd-bugs>
Component: Individual Port(s)Assignee: Jochen Neumeister <joneum>
Status: Closed Unable to Reproduce    
Severity: Affects Some People CC: joneum, mmokhi, office
Priority: --- Flags: koobs: maintainer-feedback? (joneum)
Version: Latest   
Hardware: amd64   
OS: Any   

Description Ted Milker 2020-01-21 15:51:56 UTC
I'm running FreeBSD 11.3-RELEASE-p5 and using the portupgrade tool.  I currently have mysql57-server-5.7.28_1 installed and want to upgrade for the latest CVE fixes, however it fails with the following error:

/usr/ports/databases/mysql57-server/work/mysql-5.7.29/sql/item_geofunc_internal.cc:44:63: error: no type named 'self_ip_exception' in namespace 'boost::geometry::detail::self_get_turn_points'
  catch (const boost::geometry::detail::self_get_turn_points::self_ip_exception &)
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

There appears to be an issue introduced in the mysql57-server-5.7.29 build process that prevents it from building successfully if the boost-libs port is installed on the system.  If I uninstall boost-libs, mysql57-server-5.7.29 builds and installs successfully.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-25 03:05:34 UTC
^Triage: Assign to new maintainer (ports r523992)
Comment 2 Jochen Neumeister freebsd_committer 2020-03-01 17:23:01 UTC
I cannot reproduce.
I first installed devel/boost-libs from the ports on a FreeBSD 12.1, and then databases/mysql57-server.
The installation was without problems