Bug 243673

Summary: mail/claws-mail: configure does not find a number of packages
Product: Ports & Packages Reporter: Oliver Kirchkamp <oliver>
Component: Individual Port(s)Assignee: Jochen Neumeister <joneum>
Status: Closed Not A Bug    
Severity: Affects Only Me CC: joneum, w.schwarzenfeld, x11
Priority: --- Flags: w.schwarzenfeld: maintainer-feedback? (joneum)
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
/usr/ports/mail/claws-mail/work/claws-mail-3.17.4/config.log none

Description Oliver Kirchkamp 2020-01-28 15:43:52 UTC
Created attachment 211131 [details]
/usr/ports/mail/claws-mail/work/claws-mail-3.17.4/config.log

This might be a stupid issue: I can't build claws-mail from ports on FreeBSD 12.1-RELEASE-p1 GENERIC amd64 (I can install claws-mail from pkg, though). make does not seem to find gtk (although gtk2-2.24.32 installed), and then complains about not finding a number of packages, the first one being "no Package 'xproto', required by 'x11', not found..."

I tried on two different FreeBSD 12.1-RELEASE-p1 GENERIC amd64
machines - on both make fails in a very similar way.
Comment 1 Walter Schwarzenfeld freebsd_triage 2020-01-29 12:57:49 UTC
First idea:
What you have in /etc/make.conf ? (if exists)

Second:
Could it have something to do with:
/usr/ports/UPDATING

20180731:
  AFFECTS: users of x11/xorg and all ports with USE_XORG=*proto
  AUTHOR: zeising@FreeBSD.org

  The xorg *proto packages have all been merged into one package,
  x11/xorgproto.  This might cause issues with upgrading.  If you
  get conflicts between xorgproto and old *proto packages, please
  remove the old package and install xorgproto again.

  In order to remove all orphaned ports, including all *proto port,
  the following can be used after the ports tree has been updated:
  pkg version -l \? | cut -f 1 -w | grep -v compat | xargs pkg delete -fy
Comment 2 Oliver Kirchkamp 2020-01-29 14:31:36 UTC
(In reply to Walter Schwarzenfeld from comment #1)
/etc/make.conf does not exist here.
I find no orphaned ports, in particular nothing like *proto

I have installed successfully a number of packages from ports. It always went smoothly. claws-mail seems to be the first challenge :-/
I must say that I find the line
   checking for GTK... no
strange. GTK should be installed.
Comment 3 Jochen Neumeister freebsd_committer 2020-01-30 12:44:20 UTC
i think, this is not a claws-mail problem directly. Better to give this PR to x11
Comment 4 Walter Schwarzenfeld freebsd_triage 2020-01-30 13:27:41 UTC
Add x11 to CC list.
Comment 5 Oliver Kirchkamp 2020-01-31 09:59:18 UTC
(In reply to Walter Schwarzenfeld from comment #1)

My silly mistake, actually. I force-reinstalled xorgproto, and now I can compile claws-mail. Thank you for the hint and, please, accept my apologies :-)