Bug 243817

Summary: lang/python37: Fails to link _lzma.so: Undefined symbol "lzma_check_is_supported"
Product: Ports & Packages Reporter: doctor
Component: Individual Port(s)Assignee: Kubilay Kocak <koobs>
Status: Closed DUPLICATE    
Severity: Affects Some People CC: dbaio, python, tech-lists
Priority: --- Flags: koobs: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=209355
Attachments:
Description Flags
An issue in python not accepting lzma
none
this should show you the failure
none
using source package , here is what I used to resolve the Python issue none

Description doctor 2020-02-02 19:15:14 UTC
Created attachment 211295 [details]
An issue in python not accepting lzma

sending attachment
Comment 1 Tobias Kortkamp freebsd_committer 2020-02-02 19:23:23 UTC

*** This bug has been marked as a duplicate of bug 243766 ***
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-03 00:57:39 UTC
Doctor, could you please provide:

- Exact FreeBSD version (uname -a)
- pkg version -v output (as an attachment) at the time the build issue is reproducible
- /etc/make.conf contents (as an attachment)
Comment 3 doctor 2020-02-04 01:52:29 UTC
Created attachment 211335 [details]
this should show you the failure

your request is granted .  I wonder if the issue is with the lzma.h .  I have a similar problem in archivers/libarchive
Comment 4 doctor 2020-02-04 15:29:15 UTC
I am wonder what the default include and lib order if on FreeBSD C compilation?
Comment 5 doctor 2020-02-05 21:20:17 UTC
Sure looks like /usr/include/lzma.h and -L/usr/lib/ -llzma is going AWOL
Comment 6 doctor 2020-02-12 00:24:27 UTC
Created attachment 211574 [details]
using source package , here is what I used to resolve the Python issue

Can you duplicate said fix in ports?
Comment 7 Danilo G. Baio freebsd_committer 2020-09-14 22:05:27 UTC
*** Bug 249042 has been marked as a duplicate of this bug. ***
Comment 8 Danilo G. Baio freebsd_committer 2020-09-14 23:53:32 UTC
Following the report on bug #249042 I could reproduce this issue when archivers/lzmalib is installed. (on poudriere)

And seems this PR is duplicated with bug 209355.

doctor@doctor.nl2k.ab.ca had archivers/lzmalib installed. (attachment 211335 [details])
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2020-09-20 03:50:19 UTC

*** This bug has been marked as a duplicate of bug 209355 ***