Bug 244497

Summary: graphics/gtkam: "Deleting gtkam-1.0_4.txz: new dependency: graphics/gimp" on each poudriere run
Product: Ports & Packages Reporter: Felix Palmen <felix>
Component: Individual Port(s)Assignee: Ben Woods <woodsb02>
Status: New ---    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (woodsb02)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
fix gimp dependency line none

Description Felix Palmen 2020-02-28 14:45:02 UTC
Created attachment 212022 [details]
fix gimp dependency line

The reason is a dependency line on the meta-port graphics/gimp instead of the port graphics/gimp-app actually containing the required library -- fix attached.
Comment 1 Felix Palmen 2020-05-24 08:15:32 UTC
Hello Ben,

could you please share your thoughts on this change? Are there issues with the patch I'm not aware of, e.g. some reason the dependency should really be on gimp instead of gimp-app?

I have it as a local change in my ports tree for a long time now and can't see any problems, and it resolves the issue of poudriere building this port over and over again.

BR, Felix