Bug 244609

Summary: devel/meson: meson fails to install properly on 11.3-stable
Product: Ports & Packages Reporter: jau
Component: Individual Port(s)Assignee: freebsd-gnome (Nobody) <gnome>
Status: Closed Not Enough Information    
Severity: Affects Only Me CC: jcfyecrayz, lwhsu
Priority: --- Flags: bugzilla: maintainer-feedback? (gnome)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
An example of a failing "make install" run none

Description jau 2020-03-05 12:58:44 UTC
There is something going wrong with the stage path names.
For some reason there is a redundant "/usr/local/usr/local" in the paths.
See an example below...

pkg-static: Unable to access file /usr/ports/devel/meson/work/stage/usr/local/us
r/local/share/polkit-1/actions/com.mesonbuild.install.policy:No such file or dir
ectory

I attach a complete script of a "make install" run.
Comment 1 jau 2020-03-05 13:00:34 UTC
Created attachment 212155 [details]
An example of a failing "make install" run
Comment 2 John Hein 2020-03-05 14:35:44 UTC
I cannot reproduce this.  What is in your environment & make.conf?