Bug 244712

Summary: audio/gmtp displays the same file several times when connected to Android 9
Product: Ports & Packages Reporter: Per Gunnarsson <per.gunnarsson>
Component: Individual Port(s)Assignee: Jason E. Hale <jhale>
Status: Closed FIXED    
Severity: Affects Only Me CC: freebsd-ports-local, jhale, lgfbsd
Priority: --- Flags: lgfbsd: maintainer-feedback+
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
screenshot
none
No longer duplicate files in the gmtp file manager :-)
none
patch to move to later version lgfbsd: maintainer-approval+

Description Per Gunnarsson 2020-03-10 09:50:05 UTC
Created attachment 212297 [details]
screenshot

When I connect an Android 9 device to my machine and open gmtp, the same file shows up several times in the gmtp file manager windows.
Comment 1 Per Gunnarsson 2020-07-19 21:40:58 UTC
I just checked, and now things look much better :-)

Maybe this bug report was because of some misconfiguration of mine.

Attached is a screenshot of how fine things work now:
Comment 2 Per Gunnarsson 2020-07-19 21:44:16 UTC
Created attachment 216583 [details]
No longer duplicate files in the gmtp file manager :-)
Comment 3 Per Gunnarsson 2020-07-19 21:47:52 UTC
(In reply to Per Gunnarsson from comment #1)

I forgot top mention that the nice screenshot is from Android 10
Comment 4 lgfbsd 2020-07-29 03:36:26 UTC
I updated the port to the latest (three year old) release and I'm not seeing the issue. Patch is attached, feedback encouraged.
Comment 5 lgfbsd 2020-07-29 03:36:57 UTC
diff -U 5 -r gmtp.old/Makefile gmtp/Makefile
--- gmtp.old/Makefile	2020-07-28 23:19:37.304132000 -0400
+++ gmtp/Makefile	2020-07-28 23:30:28.292466000 -0400
@@ -1,9 +1,9 @@
 # $FreeBSD: head/audio/gmtp/Makefile 517040 2019-11-08 09:27:56Z tobik $
 
 PORTNAME=	gmtp
-PORTVERSION=	1.3.11
+PORTVERSION=	1.3.10
 CATEGORIES=	audio
 MASTER_SITES=	SF/${PORTNAME}/gMTP-${PORTVERSION}/
 
 MAINTAINER=	freebsd-ports-local@be-well.ilk.org
 COMMENT=	Media Transfer Protocol (MTP) GUI client
Only in gmtp.old: Makefile~
diff -U 5 -r gmtp.old/distinfo gmtp/distinfo
--- gmtp.old/distinfo	2020-07-28 23:23:59.565882000 -0400
+++ gmtp/distinfo	2020-07-28 23:30:28.293000000 -0400
@@ -1,3 +1,3 @@
 TIMESTAMP = 1481173948
-SHA256 (gmtp-1.3.11.tar.gz) = 5a830c9c448aa2caf7a844aaa9ba38c2ac0239547366c1e6874e0080bd5f0613
-SIZE (gmtp-1.3.11.tar.gz) = 498198
+SHA256 (gmtp-1.3.10.tar.gz) = b21b9a8e66ae7bb09fc70ac7e317a0e32aff3917371a7241dea73c41db1dd13b
+SIZE (gmtp-1.3.10.tar.gz) = 496912
Comment 6 lgfbsd 2020-07-29 03:39:57 UTC
Created attachment 216846 [details]
patch to move to later version

trivial change, really...
Comment 7 lgfbsd 2020-09-09 15:00:46 UTC
This is continuing to give errors for HEAD in the build cluster, but I still can't reproduce them on my (STABLE) system, and the log pages aren't reachable through the URLs provided in the error e-mails. 

Could someone with a commit bit at least apply the update I provided?
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2020-09-09 15:05:53 UTC
(In reply to lgfbsd from comment #7)

> the log pages aren't reachable through the URLs provided in the error e-mails

Some of the build machines are ipv6-only.  You may find that you have to set up a tunnel (such as I did).
Comment 9 Jason E. Hale freebsd_committer 2021-02-03 15:29:05 UTC
(In reply to lgfbsd from comment #7)

> This is continuing to give errors for HEAD in the build cluster

It wasn't linking on HEAD because Clang >= 11 sets -fno-common by default. GCC >= 10 does this as well. It looks like this was fixed properly upstream [1], but backporting looks tedious. As a workaround, I'll add CFLAGS+=-fcommon to the port Makefile to revert to the previous compiler behavior. That line should be removed when the port is updated to the next release.

[1] https://sourceforge.net/p/gmtp/code/ci/cfd58fc3130e748f1a59c6acb24f12fc73dd2bd9/
Comment 10 commit-hook freebsd_committer 2021-02-03 17:04:25 UTC
A commit references this bug:

Author: jhale
Date: Wed Feb  3 17:03:34 UTC 2021
New revision: 563899
URL: https://svnweb.freebsd.org/changeset/ports/563899

Log:
  audio/gmtp: Update to 1.3.11

  Add temporary workaround to fix linking with Clang >= 11 and GCC >= 10

  Install license with the license framework instead of listing in PORTDOCS and
  convert to UNIX style newline

  PR:		244712
  Submitted by:	<lgfbsd@be-well.ilk.org> (maintainer)
  MFH:		2021Q1 (build fix)

Changes:
  head/audio/gmtp/Makefile
  head/audio/gmtp/distinfo
Comment 11 commit-hook freebsd_committer 2021-02-03 17:14:27 UTC
A commit references this bug:

Author: jhale
Date: Wed Feb  3 17:14:17 UTC 2021
New revision: 563902
URL: https://svnweb.freebsd.org/changeset/ports/563902

Log:
  MFH: r563899

  audio/gmtp: Update to 1.3.11

  Add temporary workaround to fix linking with Clang >= 11 and GCC >= 10

  Install license with the license framework instead of listing in PORTDOCS and
  convert to UNIX style newline

  PR:		244712
  Submitted by:	<lgfbsd@be-well.ilk.org> (maintainer)

Changes:
_U  branches/2021Q1/
  branches/2021Q1/audio/gmtp/Makefile
  branches/2021Q1/audio/gmtp/distinfo
Comment 12 Jason E. Hale freebsd_committer 2021-02-03 17:18:29 UTC
Update and build-fix committed. Sorry this has been sitting in the queue so long!