Bug 244945

Summary: lang/python37 3.7.7 fails in path 'stageUsr' and to compile readline.so
Product: Ports & Packages Reporter: mikhail.rokhin
Component: Individual Port(s)Assignee: freebsd-python (Nobody) <python>
Status: Open ---    
Severity: Affects Many People CC: canardo909, wen
Priority: --- Keywords: needs-qa, regression
Version: LatestFlags: bugzilla: maintainer-feedback? (python)
koobs: maintainer-feedback? (wen)
Hardware: Any   
OS: Any   
Description Flags
Bad path during install stage
No readline.so
FreeBSD.bug.python37-FULL.LOG--244945.txt.zip none

Description mikhail.rokhin 2020-03-21 09:18:14 UTC
fails in path 'stageUsr' during install stage:
it is: ../stageusr/..
should be: ../stage/usr/..

fails to compile readline.so :
There is no such file in correct path, but 'readline_failed.so' the only & one.

Thank you for support & development.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-21 09:22:27 UTC
@Michail Can you please attach a full build log, and:

- pkg version -v output (as an attachment)
- /etc/make.conf contents (if not empty, as an attachment)
Comment 2 mikhail.rokhin 2020-03-21 09:42:31 UTC
(In reply to Kubilay Kocak from comment #1)
No, it's run in VirtualBox.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-21 09:43:32 UTC
(In reply to mikhail.rokhin from comment #2)

We need build logs and environment information to identify why readline is failing to build (and therefore subsequently fail stage)
Comment 4 mikhail.rokhin 2020-03-21 09:47:26 UTC
Created attachment 212569 [details]
Bad path during install stage
Comment 5 mikhail.rokhin 2020-03-21 09:48:03 UTC
Created attachment 212570 [details]
No readline.so
Comment 6 mikhail.rokhin 2020-03-21 10:20:59 UTC
(In reply to Kubilay Kocak from comment #3)
Please, point me, where to find build log file?
Comment 7 mikhail.rokhin 2020-03-22 11:32:05 UTC
(In reply to Kubilay Kocak from comment #3)
I updated my world & kernel to the latest (rv359195 ; system LLVM changed from 9.x to 10.x) and tried to compile via `make install -C /usr/ports/lang/python37` and it succeeded. Previously, it failed via `portmaster -aBdvy` . Also re-compiled it with portmaster & it succeeded.

Looks like there was some failure with sed/grep script, generated bad path (../stageusr/.. instead of ../stage/usr/.. ) .
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-29 22:37:36 UTC
*** Bug 245165 has been marked as a duplicate of this bug. ***
Comment 9 canardo 2020-03-30 06:18:28 UTC
Something strange happened, here is the history:

current version is python37-3.7.6
portupgrade => python37-3.7.7 fails
make install clean of python37-3.7.7 fails => PR 245165 created
deinstall python37-3.7.6
shutdown laptop
start laptop to generate full log as requested
make install clean of python37-3.7.7 fails again, same error (see log attached)
make clean (see log attached)
make install clean of python37-3.7.7 now sucessfull (see log attached)

So I can not reproduce the problem anymore.
Could this problem be related with portupgrade usage ?

Please find full log attached
Comment 10 canardo 2020-03-30 06:19:32 UTC
Created attachment 212852 [details]
Comment 11 canardo 2020-03-31 13:37:06 UTC
As mentioned above, I don't have the problem anymore with python37.


I now have the same 'stageusr' problem for another build

/usr/ports/www/qt5-webengine # make install clean
===>  Installing for qt5-webengine-5.13.2_2
===>  Checking if qt5-webengine is already installed
===>   Registering installation for qt5-webengine-5.13.2_2
pkg-static: Unable to access file /usr/ports/www/qt5-webengine/work/stageusr/local/lib/qt5/bin/qwebengine_convert_dict:No such file or directory

I performed a reboot, make clean and make install. Problem still here.

My guess is this stageusr problem is not specific to one port.
If it is relevant, I can also open a dedicated PR for www/qt5-webengine. I'm not sure it helps.

I can run tests on my machine, and provide logs if needed.