Bug 245370

Summary: multimedia/plexmediaserver-plexpass: Missing dependencies?
Product: Ports & Packages Reporter: Dries Michiels <driesm.michiels>
Component: Individual Port(s)Assignee: Mark Felder <feld>
Status: Closed FIXED    
Severity: Affects Only Me CC: flz, j.kelly.hays, michiel
Priority: --- Flags: bugzilla: maintainer-feedback? (feld)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
ldd output on plex binary none

Description Dries Michiels 2020-04-05 10:58:08 UTC
Created attachment 213088 [details]
ldd output on plex binary

So when installing the latest plexmediaserver-plexpass (1.19.1.2589), I was unable to start the binary because of missing shared libraries. ldd output in attachments, you can see that some libraries are linked to /usr/local/lib/, which requires the presence of packages to be installed that are not shipped with Plexmediaserver itself. Is this a mistake on there side? 

Plex installed in a jail:

root@plex:/usr/local/share/plexmediaserver-plexpass # ./Plex_Media_Server
ld-elf.so.1: Shared object "libidn2.so.0" not found, required by "libcurl.so"


After installing packages below, it works fine.

[/usr/home/dries]$ pkg which /usr/local/lib/libidn2.so.0
/usr/local/lib/libidn2.so.0 was installed by package libidn2-2.3.0_1
[/usr/home/dries]$ pkg which /usr/local/lib/libintl.so.8
/usr/local/lib/libintl.so.8 was installed by package gettext-runtime-0.20.1
[/usr/home/dries]$ pkg which /usr/local/lib/libunistring.so.2
/usr/local/lib/libunistring.so.2 was installed by package libunistring-0.9.10_1
Comment 1 Florent Thoumie 2020-04-06 21:56:31 UTC
The library actually ships as part of the package, it's enough to create a symlink:

root@plex:/usr/local/share/plexmediaserver-plexpass/lib # ls -l libidn*
-rw-r--r--  1 root  wheel  312088 Mar 30 11:11 libidn2.so
lrwxr-xr-x  1 root  wheel      10 Apr  6 14:49 libidn2.so.0 -> libidn2.so
Comment 2 Mark Felder freebsd_committer 2020-04-06 22:09:20 UTC
Hello, I'm in contact with the Plex team to fix the issues with their recent builds. Appears they haven't been run-testing the artifacts they produce for FreeBSD so it wasn't noticed. Sorry for the inconvenience, but I expect we will have a fixed version soon. I don't want to mark the port BROKEN at the moment but I may have to if we don't have a solution in about 24 hours
Comment 3 Florent Thoumie 2020-04-06 22:14:41 UTC
Hey, thanks for the quick reply.

My ports-fu is a bit rusty but can't it be worked around by creating the symlink in do-install (and bumping PORTREVISION) for the time being?
Comment 4 Florent Thoumie 2020-04-06 22:17:30 UTC
... or post-patch actually, since it would be semantically more correct.
Comment 5 Mark Felder freebsd_committer 2020-04-06 22:19:13 UTC
The symlink only solves one of the problems. There is at least one other library that's absent from the release. It *may* work to install libraries with pkg but it's not recommended as we can't be sure exactly which version they linked their build against. I would hope that the library versioning of these are sane and we wouldn't encounter ABI breakage, but I'd rather not risk it and end up corrupting someone's Plex library with a workaround
Comment 6 commit-hook freebsd_committer 2020-04-08 14:15:24 UTC
A commit references this bug:

Author: feld
Date: Wed Apr  8 14:14:29 UTC 2020
New revision: 531119
URL: https://svnweb.freebsd.org/changeset/ports/531119

Log:
  multimedia/plexmediaserver-plexpass: Mark BROKEN

  Waiting on upstream to fix the artifacts for FreeBSD

  PR:		245370

Changes:
  head/multimedia/plexmediaserver-plexpass/Makefile
Comment 7 commit-hook freebsd_committer 2020-04-09 19:51:58 UTC
A commit references this bug:

Author: feld
Date: Thu Apr  9 19:51:02 UTC 2020
New revision: 531265
URL: https://svnweb.freebsd.org/changeset/ports/531265

Log:
  multimedia/plexmediaserver{-plexpass}: Update to 1.19.1.2645

  First release of 1.19.1 for FreeBSD. Previous version in the PlexPass channel was broken.

  PR:		245370

Changes:
  head/multimedia/plexmediaserver/Makefile
  head/multimedia/plexmediaserver/distinfo
  head/multimedia/plexmediaserver-plexpass/Makefile
  head/multimedia/plexmediaserver-plexpass/distinfo
Comment 8 Dries Michiels 2020-04-09 20:30:02 UTC
That update fixed it, thanks!
Comment 9 Dries Michiels 2020-05-06 08:10:16 UTC
Feld, can I close this or are you possibly trying to MFQ?