Bug 245486

Summary: x11-wm/libwraster: update to 0.95.9
Product: Ports & Packages Reporter: Marco Beishuizen <mbeis>
Component: Individual Port(s)Assignee: Hiroki Sato <hrs>
Status: Closed FIXED    
Severity: Affects Only Me CC: mjl, rhurlin
Priority: --- Flags: bugzilla: maintainer-feedback? (hrs)
mbeis: maintainer-feedback?
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
x11-wm/libwraster: update to 0.95.9
none
x11-wm/libwraster: update to 0.95.9 > adding graphics/libexif to libdepends mbeis: maintainer-approval?

Description Marco Beishuizen 2020-04-09 17:44:23 UTC
Created attachment 213225 [details]
x11-wm/libwraster: update to 0.95.9

Update WindowMaker and libwraster to new version 0.95.9.
Comment 1 Rainer Hurling freebsd_committer 2020-05-01 09:35:25 UTC
As far as I can see, there is a missing dependency, the configure script complains about: checking for libexif/exif-data.h.

Adding 'LIB_DEPENDS=libexif.so:graphics/libexif' should solve this issue.
Comment 2 Marco Beishuizen 2020-05-01 12:11:41 UTC
Created attachment 213992 [details]
x11-wm/libwraster: update to 0.95.9 > adding graphics/libexif to libdepends

Adding graphics/libexif to libdepends
Comment 3 mjl 2020-05-18 22:01:42 UTC
I applied this patch, and the one for 245487, and the patches work for me.  It would be good to get these patches integrated, as emacs requires ImageMagick7 and we can't have both ImageMagick6 and ImageMagick7 installed at the same time.