Bug 246258

Summary: audio/spotifyd: add -r to daemon
Product: Ports & Packages Reporter: Daniel Ebdrup Jensen <debdrup>
Component: Individual Port(s)Assignee: Tobias Kortkamp <tobik>
Status: Closed Unable to Reproduce    
Severity: Affects Only Me Keywords: needs-patch, needs-qa
Priority: --- Flags: bugzilla: maintainer-feedback? (tobik)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Add +r to the daemon invocation tobik: maintainer-approval-

Description Daniel Ebdrup Jensen freebsd_committer 2020-05-06 15:24:58 UTC
Created attachment 214198 [details]
Add +r to the daemon invocation

Since spotifyd apparently suffers from being quite unstable compared to most other daemons, it seems like it'll benefit from being automatically restarted, and since daemon is already being used that task can be accomplished by just adding -r.
Comment 1 Tobias Kortkamp freebsd_committer 2020-05-08 15:26:16 UTC
Comment on attachment 214198 [details]
Add +r to the daemon invocation

Please report whatever unstable behavior you have upstream:
https://github.com/Spotifyd/spotifyd/issues

Adding -r like that breaks `service spotifyd stop` and `status`.
This obviously needs to continue to work.
Comment 2 Daniel Ebdrup Jensen freebsd_committer 2020-05-10 10:05:15 UTC
Would it be possible to ask for a debug option for this port, then?
RUSTFLAGS="-g" as an environment variable should be all that's required.
Comment 3 Tobias Kortkamp freebsd_committer 2020-05-10 11:13:54 UTC
No, that's what WITH_DEBUG is for.  It works with spotifyd as much
as it does with any other port.
Comment 4 Daniel Ebdrup Jensen freebsd_committer 2020-05-10 14:02:57 UTC
I guess I was having a senior moment..
As soon as I'd finished sending the email, I remembered WITH_DEBUG - but so far the binary that I built with RUSTFLAGS="-g" hasn't crashed once whereas the official one was crashing pretty regularily.

So it looks like this is going to drag on a bit :/