Bug 246273

Summary: sysutils/aimage: [MAINTAINER] fixes build on 12 && 13
Product: Ports & Packages Reporter: Chris Hutchinson <portmaster>
Component: Individual Port(s)Assignee: Carlo Strub <cs>
Status: Closed FIXED    
Severity: Affects Some People CC: cs, daniel.engberg.lists
Priority: --- Keywords: buildisok, easy, patch, patch-ready
Version: LatestFlags: portmaster: maintainer-feedback+
Hardware: Any   
OS: Any   
Attachments:
Description Flags
svn diff for sysutils/aimage fixes build on 12 and 13
portmaster: maintainer-approval+
Build report for sysutils/aimage
none
aimage.diff
none
Revised version of patch provided by tobik@
portmaster: maintainer-approval+
QA log for 13/r358902/amd64
none
QA log on 11.x none

Description Chris Hutchinson 2020-05-07 08:23:47 UTC
Created attachment 214220 [details]
svn diff for sysutils/aimage fixes build on 12 and 13

sysutils/aimage is currently marked broken on 12 and 13
The svn diff attached to this pr(1) corrects that.

CHANGES

Makefile

tested fine on 13/amd64 - see BUILD report (also attached)

That's it.

Thanks!

--Chris
Comment 1 Chris Hutchinson 2020-05-07 08:24:49 UTC
Created attachment 214221 [details]
Build report for sysutils/aimage
Comment 2 daniel.engberg.lists 2020-05-07 08:37:26 UTC
Please use poudriere and the SSL workarounds seems very hackish.
Comment 3 Chris Hutchinson 2020-05-07 08:53:38 UTC
(In reply to daniel.engberg.lists from comment #2)
It's needed because it's less disruptive for those
on 11 which has (Open)SSL in base, and use it. This
tactic is used in many other ports as well --
openntpd, relayd, dsniff, to name only 3.
Comment 4 Chris Hutchinson 2020-05-07 09:04:44 UTC
(In reply to daniel.engberg.lists from comment #2)
If it builds in a fresh install on bare metal. It's
a better litmus test than poudriere.
Comment 5 Automation User 2020-05-10 17:34:57 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/144521461
Comment 6 Tobias Kortkamp freebsd_committer 2020-05-10 18:02:10 UTC
Created attachment 214362 [details]
aimage.diff

Try this instead. It should make it buildable with OpenSSL 1.1.
Comment 7 Chris Hutchinson 2020-05-10 18:34:37 UTC
(In reply to Tobias Kortkamp from comment #6)
I just took a peek. Yes, I can see it will
definitely work. I'll test your patch against
11 and 13 and update this pr accordingly.

Thanks Tobias! Greatly appreciated.

--Chris
Comment 8 Chris Hutchinson 2020-05-11 21:00:00 UTC
Created attachment 214396 [details]
Revised version of patch provided by tobik@

This is a revision of the one provided by tobik@
It simply removes the trailing noise from svn.
The attached patch works as intended on 13/amd64.
I will attach the QA log from that build, as well.

--Chris
Comment 9 Chris Hutchinson 2020-05-11 21:03:35 UTC
Created attachment 214397 [details]
QA log for 13/r358902/amd64

This is a QA log that proves the most recent patch
tests fine on 13/r358902/amd64

Testing on 11/amd64 now.
QA log coming real soon. :-)

--Chris
Comment 10 Chris Hutchinson 2020-05-12 00:56:24 UTC
Created attachment 214400 [details]
QA log on 11.x

OK here's the QA log that confirms the proposed patch
(svn diff) works as intended on 11.x

This should do it. The proposed patch works as intended
on 11.x as well as 13 (amd64).

Please commit.

Thanks Tobias! :-)

--Chris
Comment 11 Chris Hutchinson 2020-06-10 07:33:28 UTC
Can someone please commit this?
Comment 12 commit-hook freebsd_committer 2020-06-10 19:21:06 UTC
A commit references this bug:

Author: cs
Date: Wed Jun 10 19:20:16 UTC 2020
New revision: 538432
URL: https://svnweb.freebsd.org/changeset/ports/538432

Log:
  Fix build on 12 and 13

  PR:		246273
  Submitted by:	maintainer
  Reviewed by:	tobik@

Changes:
  head/sysutils/aimage/Makefile
  head/sysutils/aimage/files/patch-src_hash__t.h