Bug 246699

Summary: graphics/drm-devel-kmod: KLD amdgpu.ko: depends on kernnel - not available or version mismatch
Product: Ports & Packages Reporter: Brian Zou <zoujiaqing>
Component: Individual Port(s)Assignee: freebsd-x11 (Nobody) <x11>
Status: Open ---    
Severity: Affects Only Me CC: x11, zeising
Priority: --- Keywords: needs-qa
Version: LatestFlags: koobs: maintainer-feedback? (x11)
Hardware: amd64   
OS: Any   

Description Brian Zou 2020-05-24 15:04:12 UTC
# dmesg
KLD amdgpu.ko: depends on kernnel - not available or version mismatch
linker_load_file: /boot/modules/amdgpu.ko  - unsupported file type

# uname -a
FreeBSD freebsd 13.0-CURRENT #0 r360211

# pkg info drm-devel-kmod
drm-devel-kmod-5.0.g20200507
Comment 1 Niclas Zeising freebsd_committer 2020-05-29 08:50:37 UTC
It looks like your kernel and the drm kmod is out of sync.  You need to recompile drm-devel-kmod (or drm-current-kmod) from ports after upgrading your kernel on FreeBSD CURRENT, to keep them in sync.