Bug 246751

Summary: sysutils/fusefs-smbnetfs: update to 0.6.3
Product: Ports & Packages Reporter: Mikael Urankar <mikael>
Component: Individual Port(s)Assignee: Mikael Urankar <mikael>
Status: New ---    
Severity: Affects Only Me CC: fernape, mi, mi, rob2g2-freebsd, ronald-lists, timur
Priority: --- Keywords: buildisok
Version: LatestFlags: bugzilla: maintainer-feedback? (mi)
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch none

Description Mikael Urankar freebsd_committer 2020-05-26 12:26:33 UTC
Created attachment 214874 [details]
patch

pkg-message mentions etc/smb.conf which is missing on my computer but it doesn't seem necessary, can you clarify?
The XXX are still necessary?
Comment 1 Automation User 2020-05-26 13:02:30 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/149687921
Comment 2 Fernando ApesteguĂ­a freebsd_committer 2020-05-27 07:12:17 UTC
^Triage: Reporter is committer, assign accordingly.
Comment 3 Ronald Klop 2021-02-09 12:59:18 UTC
I think the maintainer timed out.
BTW: compiles fine for me on 12.2/arm64.
Comment 4 Mikhail Teterin freebsd_committer 2021-05-16 21:45:23 UTC
(In reply to Ronald Klop from comment #3)
Unfortunately, the 0.6.2 is not working for me -- though I can still read the files from SMB-shares, I can no longer overwrite them. Nor even create new ones.

Awaiting feedback from the upstream...
Comment 5 Mikael Urankar freebsd_committer 2021-05-17 07:39:29 UTC
(In reply to Mikhail Teterin from comment #4)
Have you tried the latest version (0.6.3)?
Comment 6 Mikhail Teterin freebsd_committer 2021-05-17 15:47:28 UTC
(In reply to Mikael Urankar from comment #5)
Yes, 0.6.3 is what I'm testing...
Comment 7 Mikhail Teterin freebsd_committer 2021-05-24 19:07:55 UTC
More specifically, when using the new version, trying to touch a file on a mounted share results in ENOSYS. Trying to save a new file (such as from vi), reports EINVAL.

Switching the version of libfuse from 2 to 3 and back does not change anything.
Comment 8 Mikhail Teterin freebsd_committer 2021-05-24 19:43:25 UTC
@timur -- I tried it now with Samba-4.13 and Samba-4.11. Same errors. I can read the shares, but I cannot modify them...

I see in the files/ subdirectory of the Samba ports patch(es), which add ENOSYS in a number of places. Could I ask you to check, maybe, the problem is not with smbnetfs, but rather with Samba?

Things were working last year, with Samba-4.10.
Comment 9 Mikhail Teterin freebsd_committer 2021-05-27 03:45:04 UTC
(In reply to Mikhail Teterin from comment #8)
@timur, sorry for the noise. Reverting back to smbnetfs-0.6.1 works with any of our Samba-versions...
Comment 10 Timur I. Bakeyev freebsd_committer 2021-05-27 15:07:02 UTC
(In reply to Mikhail Teterin from comment #8)
 Hi, Mikhail!

I see ENOSYS only in the vfs_freebsd code, which is, unless you explicitly enabled it, doesn't interfere.

Overall, I never used that FUSE module, so have no idea what happens.

I guess you need to review your smb.conf, striping it down to the basics and run Samba with debug enabled and try to find out what happens when you write to the shares.

Without detailed logs and description of your setup I can't say much, but even then I'm on my own, so it could be helpful to write(with logs and details) to the corresponding Samba users mailing list, seeking for help.