Bug 247232

Summary: editors/libreoffice: not changing text color
Product: Ports & Packages Reporter: bergerkos
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Open ---    
Severity: Affects Only Me CC: bergerkos, fluffy, lwhsu
Priority: --- Flags: bugzilla: maintainer-feedback? (office)
Version: Latest   
Hardware: Any   
OS: Any   

Description bergerkos 2020-06-13 11:28:47 UTC
Name           : libreoffice
Version        : 6.3.6
Installed on   : Sat Jun 13 14:23:21 2020 MSK
Origin         : editors/libreoffice
Architecture   : FreeBSD:13:amd64
Prefix         : /usr/local
Categories     : editors
Licenses       : MPL20, LGPL3+
Maintainer     : office@FreeBSD.org
WWW            : https://www.libreoffice.org/
Comment        : Full integrated office productivity suite
Options        :
	CUPS           : on
	DOCS           : on
	GNOME          : off
	GTK2           : off
	GTK3           : on
	JAVA           : off
	KDE5           : off
	MMEDIA         : on
	PGSQL          : off
	QT5            : off
	SDK            : off
	SYSTRAY        : off
	TEST           : off
	WEBDAV         : off

Text color cannot be changed. This is NOT related to "Edit > Track Changes" option being enabled/disabled, like some similar reports in the past. 
However, current port version is 6.4.4. I'll try this one now.
Comment 1 bergerkos 2020-06-13 11:55:41 UTC
Only text color cannot be changed (both GTK2 and GTK3 versions). Background color or highlight color both work fine. This is in writer. In Calc the color DOES change while you type, but once focus moves over to another cell, what you've just typed in turns black.

Besides, in GTK3 version no drop-down menus for styles and fonts choices. Also scroll-bars disappeared. Is all this somehow related to GTK3 compile options? Because in 6.4.4 GTK2 is not an option anymore.
Comment 2 Dima Panov freebsd_committer 2020-06-13 15:02:48 UTC
(In reply to bergerkos from comment #1)

This issues was mentioned in commitlog

gtk2 is removed upstream
gtk3 is unstable yet
qt5 is default vcl now 

please 'make options' and and rebuild
Comment 3 bergerkos 2020-06-22 08:22:25 UTC
Ok, it works now, the interface is all right. But there are other troubles. Don't know if this is related to Qt5 or something else.

PDF exporting is broken now. Resulting PDFs are completely unreadable (funny symbols insted of English words etc.)

version 6.4.4
Here is my configuration:
        CUPS           : on
	DOCS           : on
	GNOME          : off
	GTK3           : off
	JAVA           : off
	KF5            : off
	MMEDIA         : on
	PGSQL          : off
	QT5            : on
	SDK            : off
	TEST           : off
	WEBDAV         : on
Comment 4 bergerkos 2020-06-22 09:41:31 UTC
I confirm that this inability to export PDF correctly is linked to this Qt5-based version. Prior to that, when I struggled against gtk3-based interface, PDF exporting worked all right.

I double-checked this on a fresh installation using pre-built official packages ( now). 
XPDF, when launched from terminal, upon trying to display the exported PDF complains like this:
Syntax Error (2278): No font in show
Syntax Error: Unknown font tag 'F1'
Syntax Error (2301): No font in show/space
Syntax Error: Unknown font tag 'F2'
Syntax Error (2309): No font in show
Syntax Error: Unknown font tag 'F1'
Syntax Error (2400): No font in show/space
Syntax Error: Unknown font tag 'F2'
Comment 5 bergerkos 2020-06-22 09:47:34 UTC
Print to PDF gives the same results
Comment 6 Li-Wen Hsu freebsd_committer 2020-06-30 08:07:28 UTC
For pdf exporting, please try patch at https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247444#c27