Bug 247235

Summary: audio/pulseaudio requires POSIX semaphores after r538659
Product: Ports & Packages Reporter: aryeh.friedman
Component: Individual Port(s)Assignee: freebsd-desktop (Team) <desktop>
Status: Closed Unable to Reproduce    
Severity: Affects Only Me CC: adridg, lwhsu, rhurlin
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description aryeh.friedman 2020-06-13 12:54:32 UTC
After installing ports r538659 audio/poulseaudio (under xfce4) stopped producing sound until I added sem_load="YES" to my /boot/loader.conf and rebooted.
Comment 1 aryeh.friedman 2020-06-16 00:07:49 UTC
It turns out the sound works but the mic is completely dead despite both working before the update.
Comment 2 Adriaan de Groot freebsd_committer 2021-09-15 15:42:16 UTC
Ports cannot effectively state a requirement on kernel modules / interfaces so I do not think we can do much there. I loaded sem.ko (for kicks) and mic works, so I'm going to close this as "can't reproduce" (maybe "needs a lot more debugging info if there's to be something done about it")