Bug 247539

Summary: security/py-oauthlib: Update to 3.1.1
Product: Ports & Packages Reporter: John Hay <john>
Component: Individual Port(s)Assignee: Kubilay Kocak <koobs>
Status: Open ---    
Severity: Affects Only Me CC: lwhsu, skreuzer, swills, ygy
Priority: --- Keywords: needs-patch, needs-qa
Version: LatestFlags: koobs: maintainer-feedback+
Hardware: Any   
OS: Any   
URL: https://github.com/oauthlib/oauthlib/blob/v3.1.1/CHANGELOG.rst
Bug Depends on:    
Bug Blocks: 247540    
Attachments:
Description Flags
Patch to update to 3.1.0
none
updated security-py-oauthlib.patch none

Description John Hay 2020-06-25 16:05:39 UTC
Created attachment 215937 [details]
Patch to update to 3.1.0

Here is a patch to upgrade security/py-oauthlib to 3.1.0

https://github.com/oauthlib/oauthlib/releases

I'll send a separate one for www/py-requests-oauthlib
Comment 1 Automation User 2020-07-10 00:13:52 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/165023705
Comment 2 Li-Wen Hsu freebsd_committer 2020-08-13 08:50:41 UTC
Final ping before marking this maintainer timeout.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-13 09:38:43 UTC
This needs QA, including all dependents for version and API compatibility
Comment 4 Steven Kreuzer freebsd_committer 2021-02-23 15:49:50 UTC
Created attachment 222761 [details]
updated security-py-oauthlib.patch

This new patch extends the previous patch to also add py-mock as a dependency for testing
Comment 5 Guangyuan Yang freebsd_committer 2021-06-03 12:49:43 UTC
Maintainer timeout?
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2021-06-04 02:09:31 UTC
@Steven Apologies for the delay. This needs a .1 bump and dependencies to be updated (made OPTION'al) [1]. These also applied to the previous release, and may need to wait for a cryptography 3.0.0 update (since the cryptography dep is currently unconditional).

[1] https://github.com/oauthlib/oauthlib/blob/v3.1.1/setup.py#L19-L21